POJ 3278-Catch That Cow(BFS-一维广搜)

Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 82618 Accepted: 25955

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

Source


题目意思:

在一维坐标上,奶牛丢在了K位置,农夫从N位置去找牛。
农夫只能有三种走法:①后退一步;②前进一步;③瞬移到二倍N的位置。
每次使用一种走法花费一分钟,求找到牛要花多久。

解题思路:

BFS,分别对三种走法广搜,记录走到当前位置花费多长时间,直到N==K。

#include <iostream>
#include <cstring>
#include <cstdio>
#include<queue>
using namespace std;
const int maxn=3000000;
int n,k;
int ans=0;
bool vis[maxn];//记录是否访问
int pace[maxn];//记录走过的所有位置
int head,pos;//当前位置和要走到的位置
queue <int> q;

int bfs()
{
    q.push(n);
    while(!q.empty())
    {
        head=q.front();
        q.pop();
        for(int i=0; i<3; ++i)//有三种走法
        {
            if(i==0) pos=head-1;//后退一步
            else if(i==1) pos=head+1;//前进一步
            else pos=head*2;//二倍步数
            if(pos<0||pos>100000) continue;//超过范围
            if(vis[pos]==false)//未访问过就加入队列
            {
                q.push(pos);
                pace[pos]=pace[head]+1;//记录到达当前位置走过多少步
                //cout<<pos<<endl;
                vis[pos]=true;
            }
            if(pos==k) return pace[pos];//找到奶牛
        }
    }
}

int main()
{
    ios::sync_with_stdio(false);
    cin.tie(0);
    while(cin>>n>>k)//农夫、奶牛位置
    {
        memset(vis,false,sizeof(vis));
        if(n>=k) cout<<n-k<<endl;//如果比目标点远,就只能一步步后退挪回来
        else cout<<bfs()<<endl;
    }
    return 0;
}
/*
5 17
*/


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Description The cow bicycling team consists of N (1 <= N <= 20) cyclists. They wish to determine a race strategy which will get one of them across the finish line as fast as possible. Like everyone else, cows race bicycles in packs because that's the most efficient way to beat the wind. While travelling at x laps/minute (x is always an integer), the head of the pack expends x*x energy/minute while the rest of pack drafts behind him using only x energy/minute. Switching leaders requires no time though can only happen after an integer number of minutes. Of course, cows can drop out of the race at any time. The cows have entered a race D (1 <= D <= 100) laps long. Each cow has the same initial energy, E (1 <= E <= 100). What is the fastest possible finishing time? Only one cow has to cross the line. The finish time is an integer. Overshooting the line during some minute is no different than barely reaching it at the beginning of the next minute (though the cow must have the energy left to cycle the entire minute). N, D, and E are integers. Input A single line with three integers: N, E, and D Output A single line with the integer that is the fastest possible finishing time for the fastest possible cow. Output 0 if the cows are not strong enough to finish the race. Sample Input 3 30 20 Sample Output 7 Hint as shown in this chart: leader E pack total used this time---leader--speed--dist---minute 1------1-------5------5------25 2------1-------2------7-------4 3------2*------4------11-----16 4------2-------2------13------4 5------3*------3------16------9 6------3-------2------18------4 7------3-------2------20------4 * = leader switch Source USACO 2002 February

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值