POJ 1408-Fishnet(计算几何-根据交点求多边形面积)

Fishnet
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 2225 Accepted: 1401

Description

A fisherman named Etadokah awoke in a very small island. He could see calm, beautiful and blue sea around the island. The previous night he had encountered a terrible storm and had reached this uninhabited island. Some wrecks of his ship were spread around him. He found a square wood-frame and a long thread among the wrecks. He had to survive in this island until someone came and saved him. 

In order to catch fish, he began to make a kind of fishnet by cutting the long thread into short threads and fixing them at pegs on the square wood-frame. He wanted to know the sizes of the meshes of the fishnet to see whether he could catch small fish as well as large ones. 

The wood frame is perfectly square with four thin edges on meter long: a bottom edge, a top edge, a left edge, and a right edge. There are n pegs on each edge, and thus there are 4n pegs in total. The positions of pegs are represented by their (x,y)-coordinates. Those of an example case with n=2 are depicted in figures below. The position of the ith peg on the bottom edge is represented by (ai,0). That on the top edge, on the left edge and on the right edge are represented by (bi,1), (0,ci) and (1,di), respectively. The long thread is cut into 2n threads with appropriate lengths. The threads are strained between (ai,0) and (bi,1),and between (0,ci) and (1,di) (i=1,...,n). 

You should write a program that reports the size of the largest mesh among the (n+1)2 meshes of the fishnet made by fixing the threads at the pegs. You may assume that the thread he found is long enough to make the fishnet and the wood-frame is thin enough for neglecting its thickness. 
 

Input

The input consists of multiple sub-problems followed by a line containing a zero that indicates the end of input. Each sub-problem is given in the following format. 

a1 a2 ... an 
b1 b2 ... bn 
c1 c2 ... cn 
d1 d2 ... dn 
you may assume 0 < n <= 30, 0 < ai,bi,ci,di < 1

Output

For each sub-problem, the size of the largest mesh should be printed followed by a new line. Each value should be represented by 6 digits after the decimal point, and it may not have an error greater than 0.000001.

Sample Input

2
0.2000000 0.6000000
0.3000000 0.8000000
0.1000000 0.5000000
0.5000000 0.6000000
2
0.3333330 0.6666670
0.3333330 0.6666670
0.3333330 0.6666670
0.3333330 0.6666670
4
0.2000000 0.4000000 0.6000000 0.8000000
0.1000000 0.5000000 0.6000000 0.9000000
0.2000000 0.4000000 0.6000000 0.8000000
0.1000000 0.5000000 0.6000000 0.9000000
2
0.5138701 0.9476283
0.1717362 0.1757412
0.3086521 0.7022313
0.2264312 0.5345343
1
0.4000000
0.6000000
0.3000000
0.5000000
0

Sample Output

0.215657
0.111112
0.078923
0.279223
0.348958

Source


题目意思:

有一个1×1的木质方格,边框上有钉子,下上左右分别标记为abcd,分别给出这四个方向的N个钉子的坐标ai、bi、ci和di,则其坐标分别是(ai,0)(bi,1),(0,ci)和(1,di)。

将对应的ai和bi、ci和di位置上的钉子用网线连起来,编织成一个渔网,求渔网中被网线分割成的四边形网眼的最大面积。


解题思路:

求出网线之间形成的交点坐标,用二维数组保存起来,然后枚举每个四边形的四个顶点,计算其面积。


#include<iostream>
#include<cstdio>
#include<iomanip>
#include<cmath>
using namespace std;
const int INF=1e9;
const int MAXN=40;
const double eps=1e-3;

struct point
{
    double x,y;
} ;
point a[MAXN], b[MAXN], c[MAXN], d[MAXN];
double det(double x1,double y1,double x2,double y2)
{
    return x1*y2-x2*y1;
}
double cir(point A,point B,point C,point D)//计算 AB x CD
{
    return det(B.x-A.x, B.y-A.y, D.x-C.x, D.y-C.y);
}
double Area(point A,point B,point C,point D)
{
    return fabs(0.5*cir(A,B,A,C))+fabs(0.5*cir(A,B,A,D));
}
point intersection(point A,point B,point C,point D)//求AB与CD的交点
{
    point p;
    double area1=cir(A,B,A,C);
    double area2=cir(A,B,A,D);
    p.x=(area2*C.x-area1*D.x)/(area2-area1);//交点计算公式
    p.y=(area2*C.y-area1*D.y)/(area2-area1);
    return p;
}

int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("F:/cb/read.txt","r",stdin);
    //freopen("F:/cb/out.txt","w",stdout);
#endif
    ios::sync_with_stdio(false);
    cin.tie(0);
    int n;
    a[0].x=a[0].y=b[0].x=b[0].y=c[0].x=c[0].y=d[0].x=d[0].y=0;
    point p[MAXN][MAXN];//(n+2)*(n+2)个交点
    while(cin>>n&&n)
    {
        p[0][0].x=p[0][0].y=0;
        p[0][n+1].x=1,p[0][n+1].y=0;
        p[n+1][0].x=0,p[n+1][0].y=1;
        p[n+1][n+1].x=p[n+1][n+1].y=1;
        double ans=-1;//面积
        for(int i=0; i<4; ++i)
            for(int j=1; j<=n; ++j)
            {
                double t;
                cin>>t;
                switch(i)
                {
                case 0:
                    a[j].x=t;
                    a[j].y=0;
                    p[0][j].x=t;
                    p[0][j].y=0;
                    break;
                case 1:
                    b[j].x=t;
                    b[j].y=1;
                    p[n+1][j].x=t;
                    p[n+1][j].y=1;
                    break;
                case 2:
                    c[j].x=0;
                    c[j].y=t;
                    p[j][0].x=0;
                    p[j][0].y=t;
                    break;
                case 3:
                    d[j].x=1;
                    d[j].y=t;
                    p[j][n+1].x=1;
                    p[j][n+1].y=t;
                    break;
                }
            }
        int k=1,l=1;
        for(int i=1; i<n+1; ++i)//计算交点
        {
            for(int j=1; j<n+1; ++j)
            {
                p[i][j]=intersection(a[k],b[k],c[l],d[l]);
                ++k;
            }
            k=1;
            ++l;
        }
        for(int i=0; i<n+1; ++i)//四个一组计算面积
        {
            for(int j=0; j<n+1; ++j)
            {
                /*cout<<i<<" "<<j<<" 点="<<"("<<p[i][j].x<<","<<p[i][j].y<<") ";
                cout<<"("<<p[i][j+1].x<<","<<p[i][j+1].y<<") ";
                cout<<"("<<p[i+1][j].x<<","<<p[i+1][j].y<<") ";
                cout<<"("<<p[i+1][j+1].x<<","<<p[i+1][j+1].y<<") "<<endl;*/
                //double ar=Area(p[i][j],p[i][j+1],p[i+1][j],p[i+1][j+1]);
                double ar=Area(p[i][j],p[i+1][j+1],p[i+1][j],p[i][j+1]);
                //cout<<ar<<endl;
                if(ar>ans) ans=ar;
            }
        }
        //cout<<"答案:";
        cout<<fixed<<setprecision(6)<<ans<<endl;
    }
    return 0;
}
/*
2
0.2000000 0.6000000
0.3000000 0.8000000
0.1000000 0.5000000
0.5000000 0.6000000
2
0.3333330 0.6666670
0.3333330 0.6666670
0.3333330 0.6666670
0.3333330 0.6666670
4
0.2000000 0.4000000 0.6000000 0.8000000
0.1000000 0.5000000 0.6000000 0.9000000
0.2000000 0.4000000 0.6000000 0.8000000
0.1000000 0.5000000 0.6000000 0.9000000
2
0.5138701 0.9476283
0.1717362 0.1757412
0.3086521 0.7022313
0.2264312 0.5345343
1
0.4000000
0.6000000
0.3000000
0.5000000
0
*/


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值