Babelfish
Time Limit: 3000MS | Memory Limit: 65536K | |
Total Submissions: 42442 | Accepted: 18013 |
Description
You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.
Input
Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.
Output
Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".
Sample Input
dog ogday cat atcay pig igpay froot ootfray loops oopslay atcay ittenkay oopslay
Sample Output
cat eh loops
Hint
Huge input and output,scanf and printf are recommended.
Source
题目意思:
有一个简易词典,输入的第一个串是英语,第二个串是外来词。
然后输入一些外来词,根据词典,将其翻译成英语。
解题思路:
使用STL中的map就很简单,其中外来词是关键字。
注意词典输入完毕时以空行结尾,所以可以用gets一次读一行,再根据空格分隔;
也可以用sscanf(str,"%s%s",str1,str2);
#include<iostream>
#include<cstdio>
#include<iomanip>
#include<cmath>
#include<cstdlib>
#include<cstring>
#include <map>
#include<algorithm>
using namespace std;
map<string,string> m;
int main()
{
char str[15],str1[15],str2[15];//原串和分割后的两个串
string s;
while(gets(str)&&str[0]!='\0')
{
memset(str1,'\0',sizeof(str1));
memset(str2,'\0',sizeof(str2));
int i,j,cnt=0;
for(i=0; i<strlen(str); ++i)
{
if(str[i]==' ') break;//根据空格分隔两个字符串
else str1[i]=str[i];//第一个字符串
}
for(j=i+1; j<strlen(str); ++j)
str2[cnt++]=str[j];//第二个字符串
m[str2]=str1;//第二个字符串是关键字,存入map
}
while(cin>>s)
{
if(m[s].size()) cout<<m[s]<<endl;//如果存在则对应大小不为0
else cout<<"eh"<<endl;//不存在
}
return 0;
}