Paths on a Grid
Time Limit: 1000MS | Memory Limit: 30000K | |
Total Submissions: 25425 | Accepted: 6347 |
Description
Imagine you are attending your math lesson at school. Once again, you are bored because your teacher tells things that you already mastered years ago (this time he's explaining that (a+b)
2=a
2+2ab+b
2). So you decide to waste your time with drawing modern art instead.
Fortunately you have a piece of squared paper and you choose a rectangle of size n*m on the paper. Let's call this rectangle together with the lines it contains a grid. Starting at the lower left corner of the grid, you move your pencil to the upper right corner, taking care that it stays on the lines and moves only to the right or up. The result is shown on the left:
Really a masterpiece, isn't it? Repeating the procedure one more time, you arrive with the picture shown on the right. Now you wonder: how many different works of art can you produce?
Fortunately you have a piece of squared paper and you choose a rectangle of size n*m on the paper. Let's call this rectangle together with the lines it contains a grid. Starting at the lower left corner of the grid, you move your pencil to the upper right corner, taking care that it stays on the lines and moves only to the right or up. The result is shown on the left:
Really a masterpiece, isn't it? Repeating the procedure one more time, you arrive with the picture shown on the right. Now you wonder: how many different works of art can you produce?
Input
The input contains several testcases. Each is specified by two unsigned 32-bit integers n and m, denoting the size of the rectangle. As you can observe, the number of lines of the corresponding grid is one more in each dimension. Input is terminated by n=m=0.
Output
For each test case output on a line the number of different art works that can be generated using the procedure described above. That is, how many paths are there on a grid where each step of the path consists of moving one unit to the right or one unit up? You may safely assume that this number fits into a 32-bit unsigned integer.
Sample Input
5 4 1 1 0 0
Sample Output
126 2
Source
题目意思:
给出m行n列的矩阵,含m*n个方格,每次可以向上或向右走一步,计算从矩阵左下方走到右上方共有多少种不同的方法。
解题思路:
组合数学,向上有m步可走,向右有n步可走,
从矩阵左下方走到右上方共要走m+n步,选出m步,则剩下的n步一定是固定的(反之亦然),所以步数是C(m+n,max(m,n))。
#include<iostream>
#include<cstdio>
#include<iomanip>
#include<cmath>
#include<cstdlib>
#include<cstring>
#include<map>
#include<algorithm>
#include<vector>
#include<queue>
using namespace std;
#define INF 0x3f3f3f3f
#define MAXN 5050
unsigned long long c(unsigned long long x,unsigned long long y)//计算C(x,y)
{
unsigned long long s=1,i,j;
for (i=y+1, j=1; i<=x; i++,j++)
s=s*i/j;
return s;
}
int main()
{
#ifdef ONLINE_JUDGE
#else
freopen("F:/cb/read.txt","r",stdin);
//freopen("F:/cb/out.txt","w",stdout);
#endif
ios::sync_with_stdio(false);
cin.tie(0);
unsigned long long n,m,x;
while(cin>>n>>m)
{
if(n==0&&m==0) break;
x=max(m,n);
cout<<c(n+m,x)<<endl;
}
return 0;
}
/*
5 4
1 1
0 0
*/