POJ 3130-How I Mathematician Wonder What You Are!(计算几何-星形-半平面交逆时针模板)

How I Mathematician Wonder What You Are!
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 3730 Accepted: 2007

Description

After counting so many stars in the sky in his childhood, Isaac, now an astronomer and a mathematician uses a big astronomical telescope and lets his image processing program count stars. The hardest part of the program is to judge if shining object in the sky is really a star. As a mathematician, the only way he knows is to apply a mathematical definition of stars.

The mathematical definition of a star shape is as follows: A planar shape F is star-shaped if and only if there is a point C ∈ F such that, for any point P ∈ F, the line segment CP is contained in F. Such a point C is called a center of F. To get accustomed to the definition let’s see some examples below.

The first two are what you would normally call stars. According to the above definition, however, all shapes in the first row are star-shaped. The two in the second row are not. For each star shape, a center is indicated with a dot. Note that a star shape in general has infinitely many centers. Fore Example, for the third quadrangular shape, all points in it are centers.

Your job is to write a program that tells whether a given polygonal shape is star-shaped or not.

Input

The input is a sequence of datasets followed by a line containing a single zero. Each dataset specifies a polygon, and is formatted as follows.

n 
x1y1
x2y2

xnyn

The first line is the number of vertices, n, which satisfies 4 ≤ n ≤ 50. Subsequent n lines are the x- and y-coordinates of the n vertices. They are integers and satisfy 0 ≤ xi ≤ 10000 and 0 ≤ yi ≤ 10000 (i = 1, …, n). Line segments (xiyi)–(xi + 1yi + 1) (i = 1, …, n − 1) and the line segment (xnyn)–(x1y1) form the border of the polygon in the counterclockwise order. That is, these line segments see the inside of the polygon in the left of their directions.

You may assume that the polygon is simple, that is, its border never crosses or touches itself. You may assume assume that no three edges of the polygon meet at a single point even when they are infinitely extended.

Output

For each dataset, output “1” if the polygon is star-shaped and “0” otherwise. Each number must be in a separate line and the line should not contain any other characters.

Sample Input

6 
66 13 
96 61 
76 98 
13 94 
4 0 
45 68 
8 
27 21 
55 14 
93 12 
56 95 
15 48 
38 46 
51 65 
64 31 
0

Sample Output

1
0

Source


逆时针给出N个点的坐标,计算其是否能够构成星形。
星形的数学定义如下:当且仅当存在点C∈F时,平面形状F为星形,使得对于任何点P∈F,线段CP包含在F中。点C被称为F的中心。

#include<iostream>
#include<cstdio>
#include<iomanip>
#include<cmath>
#include<cstdlib>
#include<cstring>
#include<map>
#include<algorithm>
#include<vector>
#include<queue>
using namespace std;
#define INF 0xfffffff
#define MAXN 275000
const double eps=1e-8;
const int maxn=105;

int dq[maxn],top,bot,pn,order[maxn],ln;
struct Point
{
    double x,y;
} p[maxn];

struct Line
{
    Point a,b;
    double angle;
} l[maxn];

int dblcmp(double k)
{
    if(fabs(k)<eps) return 0;
    return k>0?1:-1;
}

double multi(Point p0,Point p1,Point p2)
{
    return (p1.x-p0.x)*(p2.y-p0.y)-(p1.y-p0.y)*(p2.x-p0.x);
}

bool cmp(int u,int v)
{
    int d=dblcmp(l[u].angle-l[v].angle);
    if (!d) return dblcmp(multi(l[u].a,l[v].a,l[v].b))>0;//大于0取向量左半部分为半平面,小于0,取右半部分
    return d<0;
}

void getIntersect(Line l1,Line l2,Point& p)
{
    double dot1,dot2;
    dot1=multi(l2.a,l1.b,l1.a);
    dot2=multi(l1.b,l2.b,l1.a);
    p.x=(l2.a.x*dot2+l2.b.x*dot1)/(dot2+dot1);
    p.y=(l2.a.y*dot2+l2.b.y*dot1)/(dot2+dot1);
}

bool judge(Line l0,Line l1,Line l2)
{
    Point p;
    getIntersect(l1,l2,p);
    return dblcmp(multi(p,l0.a,l0.b))<0;//大于小于符号与上面cmp()中注释处相反
}

void addLine(double x1,double y1,double x2,double y2)
{
    l[ln].a.x=x1;
    l[ln].a.y=y1;
    l[ln].b.x=x2;
    l[ln].b.y=y2;
    l[ln].angle=atan2(y2-y1,x2-x1);
    order[ln]=ln;
    ln++;
}

void halfPlaneIntersection()
{
    sort(order,order+ln,cmp);
    int j=0;
    for(int i=1; i<ln; i++)
        if(dblcmp(l[order[i]].angle-l[order[j]].angle)>0)
            order[++j]=order[i];
    ln=j+1;
    dq[0]=order[0];
    dq[1]=order[1];
    bot=0;
    top=1;
    for(int i=2; i<ln; i++)
    {
        while(bot<top&&judge(l[order[i]],l[dq[top-1]],l[dq[top]])) top--;
        while(bot<top&&judge(l[order[i]],l[dq[bot+1]],l[dq[bot]])) bot++;
        dq[++top]=order[i];
    }
    while(bot<top&&judge(l[dq[bot]],l[dq[top-1]],l[dq[top]])) top--;
    while(bot<top&&judge(l[dq[top]],l[dq[bot+1]],l[dq[bot]])) bot++;
}

bool isThereACore()
{
    if (top-bot>1) return true;
    return false;
}

int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("G:/cbx/read.txt","r",stdin);
    //freopen("G:/cbx/out.txt","w",stdout);
#endif
    while(~scanf("%d",&pn))
    {
        if(pn==0) break;
        ln=0;
        for(int i=0; i<pn; i++)
            scanf("%lf%lf",&p[i].x,&p[i].y);
        for(int i=0; i<pn-1; i++)
            addLine(p[i].x,p[i].y,p[i+1].x,p[i+1].y);
        addLine(p[pn-1].x,p[pn-1].y,p[0].x,p[0].y);
        halfPlaneIntersection();
        if(isThereACore()) printf("1\n");
        else printf("0\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值