Prime Ring Problem (dfs)

Prime Ring Problem

Time Limit: 2000/1000ms (Java/Others)

Problem Description:

         A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime. 

Note: the number of first circle should always be 1.

Input:

n (0 < n < 20). 

Output:

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case even if there is no answer.

Sample Input:

6
8

Sample Output:

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2



总算能靠自己AC一道DFS题目了,虽然期间bug无数,改了又改,以下是代码:

#include<bits/stdc++.h>
#define ll long long
using namespace std;
int a[30];
int x = 1;
int n;
int save[30];
void dfs(int pre,int s)
{
    if(s == n+1)
    {
        if(pre+1==3||pre+1==5||pre+1==7||pre+1==11||pre+1==13||pre+1==17||pre+1==19||pre+1==23||pre+1==29||pre+1==31||pre+1==37)
        {
            for(int i = 1;i < n;i++)
                printf("%d ",save[i]);
            printf("%d\n",save[n]);
        }
        return ;
    }
    for(int i = 2;i <= n;i++)
    {
        if(!a[i]&&(i+pre==3||i+pre==5||i+pre==7||i+pre==11||i+pre==13||i+pre==17|pre+i==19||pre+i==23||pre+i==29||pre+i==31||pre+i==37))
        {
                a[i] = 1;
                save[s] = i;
                dfs(i,s+1);
                a[i] = 0;
        }
        else if(i == n)
            return ;
    }
}
int main()
{
    while(scanf("%d",&n) != EOF)
    {
        printf("Case %d:\n",x++);
        save[1] = 1;
        if(n != 19)
            dfs(1,2);
        printf("\n");
    }
    return 0;
}

CCF大数据与计算智能大赛-面向电信行业存量用户的智能套餐个性化匹配模型联通赛-复赛第二名-【多分类,embedding】.zip项目工程资源经过严格测试可直接运行成功且功能正常的情况才上传,可轻松复刻,拿到资料包后可轻松复现出一样的项目,本人系统开发经验充足(全领域),有任何使用问题欢迎随时与我联系,我会及时为您解惑,提供帮助。 【资源内容】:包含完整源码+工程文件+说明(如有)等。答辩评审平均分达到96分,放心下载使用!可轻松复现,设计报告也可借鉴此项目,该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的。 【提供帮助】:有任何使用问题欢迎随时与我联系,我会及时解答解惑,提供帮助 【附带帮助】:若还需要相关开发工具、学习资料等,我会提供帮助,提供资料,鼓励学习进步 【项目价值】:可用在相关项目设计中,皆可应用在项目、毕业设计、课程设计、期末/期中/大作业、工程实训、大创等学科竞赛比赛、初期项目立项、学习/练手等方面,可借鉴此优质项目实现复刻,设计报告也可借鉴此项目,也可基于此项目来扩展开发出更多功能 下载后请首先打开README文件(如有),项目工程可直接复现复刻,如果基础还行,也可在此程序基础上进行修改,以实现其它功能。供开源学习/技术交流/学习参考,勿用于商业用途。质量优质,放心下载使用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值