Tree Traversals Again (树的遍历)(栈)

03-树3 Tree Traversals Again(25 分)

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.


Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

 
   

3 4 2 6 5 1

题意:通过栈和中序遍历的方式输入一棵树,然后需要输出他的后序遍历

AC代码:

#include <cstdio>   
#include <iostream> 
#include <algorithm> 
#include <cmath> 
#include <cstdlib> 
#include <cstring> 
#include <vector> 
#include <list> 
#include <map> 
#include <stack> 
#include <queue> 
using namespace std; 
#define ll long long
typedef struct Tree
{
	int data;
	Tree *l,*r;	 	
}*BiTree;
stack<int> q;
int sum;
int n;
void Creat(BiTree &T)
{
	if(sum == 2*n)
		return;
	char x[11];
	cin >> x;
	sum++;
	if(x[1] == 'u')
	{
		int x;
		cin >> x;
		q.push(x);
		T = new Tree;
		T->l = T->r = NULL;
		Creat(T->l);
		T->data = q.top();
		q.pop();
		Creat(T->r);
	}
	return;
}
void endorder(BiTree T)
{
	if(!T)
		return;
	endorder(T->l);
	endorder(T->r);
	if(sum == 2*n)
		cout << T->data;
	else
		cout <<' '<< T->data;
	sum++;
}
int main() 
{
	BiTree T;
	cin >> n;
	sum = 0;
	Creat(T);
	endorder(T);
	cout << endl;
    //cout << "AC" <<endl; 
    return 0; 
} 
反思:一开始把栈写成了队列......
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值