POJ-3984(BFS) 迷宫问题

定义一个二维数组:

int maze[5][5] = {

0, 1, 0, 0, 0,

0, 1, 0, 1, 0,

0, 0, 0, 0, 0,

0, 1, 1, 1, 0,

0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。
Input
一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。
Output
左上角到右下角的最短路径,格式如样例所示。
Sample Input
0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
Sample Output
(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

  • 要输出路径 记录父节点
  • 好像自己构造队列比queue要好用一些,省着另处理父亲节点了
#include <iostream>
#include <cstring>
using namespace std;

int map[ 5 ][ 5 ];
struct node
{
    int x;
    int y;
    int fa;
}que[100];
int head = 0,tail = 1;
int dir[4][2]={{ 0, -1 }, { 1, 0 },{ 0, 1 },{ -1, 0 }};

void print(int i){
    if (que[i].fa != -1){
        print(que[i].fa);
        cout<<"("<<que[i].x<<", "<<que[i].y<<")"<<endl;
    }
}

void solve( int x, int y){
    que[head].x = x;
    que[head].y = y;
    que[head].fa = -1;
    while ( head < tail){
        int i;
        for ( i = 0; i < 4; i++ ){
            int x = que[head].x + dir[i][0];
            int y = que[head].y + dir[i][1];
            if ( x < 0 || x >= 5 || y < 0 || y >= 5 ||map[ x ][ y ]  ) continue;
            else{
                map[ x ][ y ] = -1;
                que[tail].x = x;
                que[tail].y = y;
                que[tail].fa = head;
                tail++;
            }
            if ( x == 4 && y == 4 ){
                cout<<"(0, 0)"<<endl;
                print(head);
                cout<<"(4, 4)"<<endl;
            }
        }
        head++;
    }
}

int main(){
    for ( int i = 0; i < 5; i++ ){
        for ( int j = 0; j < 5; j++ ){
            cin>>map[ i ][ j ];
        }
    }
    solve(0,0);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值