HDU2141(二分)

Description

Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X. 

Input

There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers. 

Output

For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO". 

Sample Input

3 3 3

1 2 3

1 2 3

1 2 3

3

1

4

1

0

Sample Output

Case 1:

NO

YES

NO


思路:

将A,B数组元素分别相加,得到D数组,排序,枚举C数组元素,在D中二分查找元素X-Ck。

#include<cstdio>
#include<algorithm>
#define maxn 505
using namespace std;
int A[maxn],B[maxn],C[maxn],D[maxn*maxn];

int main()
{
    int L,N,M, tc = 0;
    while(~scanf("%d%d%d",&L,&N,&M))
    {
        for(int i = 0; i < L; i++) scanf("%d", A+i);
        for(int i = 0; i < N; i++) scanf("%d", B+i);
        for(int i = 0; i < M; i++) scanf("%d", C+i);
        int S, tmp, len = 0;
        scanf("%d", &S);
        for(int i = 0; i < L; i++)
            for(int k = 0; k < N; k++)
                D[len++] = A[i]+B[k];
        printf("Case %d:\n", ++tc);
        sort(D,D+len);
        for(int i = 0; i < S; i++)
        {
            int tag = 0;
            scanf("%d", &tmp);
            for(int j = 0; j < M && !tag; j++)
            {
                int low = 0, high = len - 1, mid;
                while(low <= high)
                {
                    mid = (low+high)>>1;
                    if(D[mid] > tmp - C[j])
                        high = mid - 1;
                    else if(D[mid] < tmp - C[j])
                        low = mid + 1;
                    else
                        {
                            tag = 1;
                            break;
                        }
                }
            }
            if(tag)
                printf("YES\n");
            else
            printf("NO\n");
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值