Can you find it?(二分查找)

Can you find it?(二分查找)

Description:

Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
Output
For each case, firstly you have to print the case number as the form “Case d:”, then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print “YES”, otherwise print “NO”.
Sample Input
3 3 3
1 2 3
1 2 3
1 2 3
3
1
4
10
Sample Output
Case 1:
NO
YES
NO

题意:给出三组数,要求从每组数中找到一个值,使三个数相加等于输入的查询值,判断是否存在这样的三个数。

题解:先把A,B两组数的和存在一个单独的数组里并进行排序,然后遍历C数组中的每个值,对于C中的每个值,在存A,B和的数组中用二分查找是否存在一个值等于X-X-C。

AC代码:

#include <stdio.h>
#include <string.h>
#include <math.h>
#include <algorithm>
#include <iostream>
using namespace std;
long long d[250010];
int main()
{
    int L,M,N,a[505],b[505],c[505],p=1;
    while(~scanf("%d%d%d",&L,&M,&N))
    {
        for(int i=0; i<L; i++)
            scanf("%d",&a[i]);
        for(int i=0; i<M; i++)
            scanf("%d",&b[i]);
        for(int i=0; i<N; i++)
            scanf("%d",&c[i]);
        int k=0,s,num;
        for(int i=0; i<L; i++)     //先求出a,b数组中元素相加的和;
            for(int j=0; j<M; j++)
                d[k++]=a[i]+b[j];
       sort(d,d+k);              //二分必排序;
        cin>>s;
        printf("Case %d:\n",p++);
        while(s--)
        {
            cin>>num;
            int flag=0;
            for(int i=0; i<N; i++)     
            {
                int l=0,r=k-1,mid=0;
                while(l<=r)
                {
                    mid=l+(r-l)/2;     
                    if(d[mid]==num-c[i])
                    {
                        flag=1;         //存在这个数就标记一下;
                        break;
                    }
                    else if(d[mid]>num-c[i])
                        r=mid-1;
                    else
                        l=mid+1;
                }
            }
            if(flag==1)
                printf("YES\n");
            else
                printf("NO\n");
        }

    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值