hdu1312Red and Black

Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11411    Accepted Submission(s): 7096


Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
 

Sample Input
  
  
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 

Sample Output
  
  
45 59 6 13
 /*
题目类型:深搜
题目大意:有一个迷宫,一个人遍历完所有的能到达的点走出迷宫需要多少步路
题解:整个点所有的和为sum=H*W,每一个点去搜索,如果是"#"或者当前点不能到达起点,sum--,输出sum即可
  */
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
using namespace std;
int d[4][2]={{0,1},{1,0},{0,-1},{-1,0}};
int a[25][25],visit[25][25];
int W,H;		//矩形长宽
int h,l;		//起点
int sum;		//和
int flag;		//标记
void dfs(int row,int col)	//row代表行,col代表列
{
	int i,j;
	if(row==h&&col==l)
	{
		flag=1;
		return ;
	}
	for(i=0;i<4;i++)
	{
		int x=row+d[i][0];
		int y=col+d[i][1];
		if(!visit[x][y]&&x>=0&&x<H&&y>=0&&y<W&&a[x][y]!=0)
		{
			visit[x][y]=1;
			dfs(x,y);
			if(flag)
				return ;
		}
	}
}
int main()
{
	int i,j;

	while(scanf("%d%d",&W,&H)!=EOF&&W&&H)	//H是行,W是列
	{
		sum=W*H;	//和
		for(i=0;i<H;i++)
		{
			for(j=0;j<W;j++)
			{
				char ch;
				cin>>ch;
				if(ch=='.')
					a[i][j]=1;
				else if(ch=='#')
				{
					a[i][j]=0;
					//sum--;
				}
				else if(ch=='@')
				{
					a[i][j]=1;
					h=i;
					l=j;
				}
			}
		}
		//cout<<h<<"  "<<l<<endl;
		for(i=0;i<H;i++)
		{
			for(j=0;j<W;j++)
			{
				memset(visit,0,sizeof(visit));
				flag=0;
				if(a[i][j]==1)
				{
					visit[i][j]=1;
					dfs(i,j);
				}
				if(flag==0)		//遇到#也是sum--
					sum--;
			}
		}
		
		cout<<sum<<endl;
	}
	return 0;
}

/*
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
2 3
.#
##
.@
  */

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值