Mondriaan's Dream

http://poj.org/problem?id=2411

 

Mondriaan's Dream

Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 20824 Accepted: 11733

Description

Squares and rectangles fascinated the famous Dutch painter Piet Mondriaan. One night, after producing the drawings in his 'toilet series' (where he had to use his toilet paper to draw on, for all of his paper was filled with squares and rectangles), he dreamt of filling a large rectangle with small rectangles of width 2 and height 1 in varying ways. 


Expert as he was in this material, he saw at a glance that he'll need a computer to calculate the number of ways to fill the large rectangle whose dimensions were integer values, as well. Help him, so that his dream won't turn into a nightmare!

Input

The input contains several test cases. Each test case is made up of two integer numbers: the height h and the width w of the large rectangle. Input is terminated by h=w=0. Otherwise, 1<=h,w<=11. 

Output

For each test case, output the number of different ways the given rectangle can be filled with small rectangles of size 2 times 1. Assume the given large rectangle is oriented, i.e. count symmetrical tilings multiple times. 

Sample Input

1 2
1 3
1 4
2 2
2 3
2 4
2 11
4 11
0 0

Sample Output

1
0
1
2
3
5
144
51205
//#include<bits/stdc++.h>
//#include <unordered_map>
//#include<unordered_set>
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<set>
#include<climits>
#include<queue>
#include<cmath>
#include<stack>
#include<map>
#include<string>
using namespace std;
#define LL long long
#define ULL unsigned long long
#define MT(a,b) memset(a,b,sizeof(a))
const int INF  =  0x3f3f3f3f;
const int O    =  1e5;
const int mod  =  1e9+7;
const int maxn =  1e2+5;
const double PI  =  3.141592653589;
const double E   =  2.718281828459;


//横放 :1 1
//
//竖放 :0
//     1

int n, m;
LL dp[12][1<<12];
vector<int>Next[1<<12];

void dfs(int list, int first, int next)
{
    if(list==m)
    {
        Next[first].push_back(next);
        return ;
    }
    if((first&(1<<list))==0) //若first第list列为0,next第list列必为1
        dfs(list+1, first, next|(1<<list));
    else  //若first第list列为1
    {
        dfs(list+1, first, next); //竖放
        if( list<m-1  &&  (first & (1<<(list+1))) )
            dfs(list+2, first, next | (1<<list) | (1<<(list+1))); //横放
    }
}

int main()
{
    while(scanf("%d%d",&n,&m)&&n+m)
    {
        if(n*m%2==1)
        {
            printf("0\n");
            continue;
        }
        if(m&1) swap(n,m);
        for(int first=0;first<(1<<m);first++)
        {
            Next[first].clear();
            dfs(0, first, 0);
        }
        int Max = (1<<m)-1;
        MT(dp, 0); dp[0][Max] = 1; //第0行相当于一个底,确保第1行既能横放也能竖放
        for(int i=1;i<=n;i++)
        {
            for(int state=0;state<=Max;state++)
            {
                ULL siz = Next[state].size();
                for(int j =0; j<siz; j++)
                    dp[i][ Next[state][j] ] += dp[i-1][state];//状态转移
            }
        }
        printf("%lld\n", dp[n][Max]);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值