(HDU)How many integers can you find(容斥原理 -好题)




点击打开题目





How many integers can you find

Time Limit: 12000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8740    Accepted Submission(s): 2594


Problem Description
  Now you get a number N, and a M-integers set, you should find out how many integers which are small than N, that they can divided exactly by any integers in the set. For example, N=12, and M-integer set is {2,3}, so there is another set {2,3,4,6,8,9,10}, all the integers of the set can be divided exactly by 2 or 3. As a result, you just output the number 7.
 

Input
  There are a lot of cases. For each case, the first line contains two integers N and M. The follow line contains the M integers, and all of them are different from each other. 0<N<2^31,0<M<=10, and the M integer are non-negative and won’t exceed 20.
 

Output
  For each case, output the number.
 

Sample Input
      
      
12 2 2 3
 

Sample Output
      
      
7
 

Author
wangye
 

Source
 



题意:找出从1至数字N里面有几个能整除M数组里面的数字。注:不包含N。


题解 :1.M数组里面可能为0,和大于N的数字,在输入时应当直接排除。

     2.M数组里面有可能不全部互质,要用Gcd和lcm求最大公倍数来代替被除数。

             3.利用容斥原理进行“奇加偶减”。

代码:

#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;

int n;
int m;
int a[15];

int gcd(int a,int b){//gcd模板
	return a==0?b:gcd(b%a,a);
}

int lcm(int a,int b){//lcm模板
	return a/gcd(a,b)*b;
}

int main(){
	while(cin>>n>>m){
		n=n-1;
		int temp;
		for(int i=0;i<m;i++){
			cin>>temp;
			if(temp>0&&temp<=n)//判断输入是否符合大于0 ,小于n
			a[i]=temp;
			else{
				m--;
				i--;
			}
		}
		int ans=0;
		for(int i=1;i<(1<<m);i++){//容斥原理,利用二进制进行列举情况
			int ant=0;
			int ride=1;
			for(int j=0;j<m;j++){
				if(i & (1<<j)){//哪一个数被选作被除数
					ant++;//记录被除因子的个数
					ride=lcm(ride,a[j]);//利用lcm求积,不能直接相乘
				}
			}
			if(ant & 1)//是否为奇数
			ans+=n/ride;
			else
			ans-=n/ride;
		}
		cout<<ans<<endl;
	}
	return 0;
}





How many integers can you find

Time Limit: 12000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8740    Accepted Submission(s): 2594


Problem Description
  Now you get a number N, and a M-integers set, you should find out how many integers which are small than N, that they can divided exactly by any integers in the set. For example, N=12, and M-integer set is {2,3}, so there is another set {2,3,4,6,8,9,10}, all the integers of the set can be divided exactly by 2 or 3. As a result, you just output the number 7.
 

Input
  There are a lot of cases. For each case, the first line contains two integers N and M. The follow line contains the M integers, and all of them are different from each other. 0<N<2^31,0<M<=10, and the M integer are non-negative and won’t exceed 20.
 

Output
  For each case, output the number.
 

Sample Input
       
       
12 2 2 3
 

Sample Output
       
       
7
 

Author
wangye
 

Source
 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值