How many integers can you find (HDU-1796)(容斥原理)

  Now you get a number N, and a M-integers set, you should find out how many integers which are small than N, that they can divided exactly by any integers in the set. For example, N=12, and M-integer set is {2,3}, so there is another set {2,3,4,6,8,9,10}, all the integers of the set can be divided exactly by 2 or 3. As a result, you just output the number 7.

Input

  There are a lot of cases. For each case, the first line contains two integers N and M. The follow line contains the M integers, and all of them are different from each other. 0<N<2^31,0<M<=10, and the M integer are non-negative and won’t exceed 20.

Output

  For each case, output the number.

Sample Input

12 2
2 3

Sample Output

7

题意:让你求在 1-(n-1) 中能够被输入的数字整除的数字的数量。

思路:这道题的话,首先看到整除的字样,并且范围是1~n求能被输入的数字整除的数量,就能想到是用容斥原理。这里的话,我们用位运算的板子,枚举状态,奇加偶减,注意给定的数字为0的情况即可。

AC代码:

#include <stdio.h>
#include <string>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <math.h>
#include <queue>
#include <stack>
#include <map>
#include <set>
typedef long long ll;
const int maxx=10010;
const int mod=10007;
const int inf=0x3f3f3f3f;
using namespace std;
ll n,m;
ll fac[maxx];
ll gcd(ll a,ll b)
{
    return b==0?a:gcd(b,a%b);
}
ll lcm(ll a,ll b)
{
    return a/gcd(a,b)*b;
}
ll solve(ll n,ll cnt)
{
    ll ans=0;
    for(ll i=1; i<(1<<cnt); i++)
    {
        ll ones=0,mult=1;
        for(ll j=0; j<cnt; j++)
        {
            if(i&(1<<j))
            {
                ones++;
                mult=lcm(mult,fac[j]);
            }
        }
        if(ones&1)
            ans+=(n-1)/mult;
        else
            ans-=(n-1)/mult;
    }
    return ans;
}
int main()
{
    while(~scanf("%lld%lld",&n,&m))
    {
        ll x;
        ll tot=0;
        for(int i=1; i<=m; i++)
        {
            scanf("%lld",&x);
            if(x!=0)
                fac[tot++]=x;
        }
        printf("%lld\n",solve(n,tot));
    }
    return 0;
}


 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值