【HDU 1159】 Common Subsequence(dp —lcs模板题)


点击打开题目


Common Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 40637    Accepted Submission(s): 18752


Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
 

Sample Input
  
  
abcfbc abfcab programming contest abcd mnp
 

Sample Output
  
  
4 2 0
 

Source
 

Recommend
Ignatius   |   We have carefully selected several similar problems for you:   1087  1176  1003  1058  1069 

题意:求最大的公共子序列

题解:lcs模板题


代码:


#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
using namespace std;
const int MAX=1e3+10;
int dp[MAX][MAX];
char str1[MAX],str2[MAX];
int main(){
	while(~scanf("%s %s",str1+1,str2+1)){
		str1[0]=str2[0]='0';
		memset(dp,0,sizeof(dp));
		int len1=strlen(str1)-1;
		int len2=strlen(str2)-1;
		
		for(int i=1;i<=len1;i++){
			for(int j=1;j<=len2;j++){
				if(str1[i] == str2 [j])
				dp[i][j]=dp[i-1][j-1]+1;
				else
				dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
			}
		}
		cout<<dp[len1][len2]<<endl;
	}
}


附:lcs算法



还可以回溯求最长公共子序列元素:


代码:


/*
LCS

BDCABA
ABCBDAB

dp[1][2] = 1
dp[1][1] = 0
dp[2][1] = 0

//子串:连续
//子序列:可以不连续 
// LCS

dp[i][j]//第一个字符串在第i个字符前且第二个串在第j个字符前可构成的最长子序列的长度 

dp[i][j] = 			0  						i=0 || j=0
				dp[i-1][j-1]+1    		 str1[i]==str2[j]
			max(dp[i-1][j],dp[i][j-1])	 str1[i]!=str2[j]
*/
#include<cstdio>
#include<cstring>
#include<stack>
#include<algorithm>
using namespace std;
int main()
{
	char str1[20];
	char str2[20];
	scanf ("%s %s",str1+1,str2+1);
	str1[0] = str2[0] = '0';
	int l1 = strlen(str1)-1;
	int l2 = strlen(str2)-1;
	int dp[20][20] = {0};//0  						i=0 || j=0
	
	for (int i = 1 ; i <= l1 ; i++)
	{
		for (int j = 1 ; j <= l2 ; j++)
		{
			if (str1[i] == str2[j])//dp[i-1][j-1]+1    		 str1[i]==str2[j]
				dp[i][j] = dp[i-1][j-1] + 1;
			else
				dp[i][j] = max(dp[i-1][j],dp[i][j-1]);//max(dp[i-1][j],dp[i][j-1])	 str1[i]!=str2[j]
		}
	}
	
	//回溯求LCS 
	int pos1 = l1;
	int pos2 = l2;
	stack<char> S;
	while (pos1 > 0 && pos2 > 0)
	{
		if (str1[pos1] == str2[pos2])
		{
			S.push(str1[pos1]);
			pos1--;
			pos2--;
		}
		else if (dp[pos1-1][pos2] > dp[pos1][pos2-1])
			pos1--;
		else
			pos2--;
	}
	while (!S.empty())
	{
		printf ("%c%c",S.top(),(S.size() == 1) ? '\n' : ' ');
		S.pop();
	}
	printf ("%d\n",dp[l1][l2]);
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值