[POJ 2406]Power Strings(kmp)


点击打开题目


Power Strings
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 50554 Accepted: 21087

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

Source


题意:就是问一个字符串写成(a)^n的形式,求最大的n.

题解:根据KMP的next函数的性质,已知字符串t第K个字符的next[k],那么d=k-next[k],如果k%d==0,那么t[1……k]最多可均匀的分成k/d份。也就是可以生成一个长度为d的重复度为k/d的字串。


代码:



#include<iostream>
#include<cstring>
#include<stdio.h>
using namespace std;

const int MAX=1e6+10;
char s[MAX];
char t[MAX];
int Next[MAX]; 
int n,m;
int ans=0;

void getNext(){
	int i=0,j=0;
	Next[0]=-1;
	j=Next[i];
	while(i<m){
		if(j==-1||t[i]==t[j]){
			i++;
			j++;
			Next[i]=t[i]==t[j]?Next[j]:j;
		}
		else{
			j=Next[j];
		}
	}
}

int main(){
	while(~scanf("%s",t)){
		if(t[0]=='.')
		break;
		m=strlen(t);
		getNext();
		ans=1;//最小是1,不初始化会WA
		if(m%(m-Next[m])==0)//判断是否能整除
		ans=m/(m-Next[m]);
		cout<<ans<<endl;
	}
	return 0;
}










  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值