POJ 2406 Power Strings(kmp)

Power Strings
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 47749 Accepted: 19903

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

Source

Waterloo local 2002.07.01


题意: 给出一个字符串,找出其循环节并判断其循环了几次。


本题考查了对next数组的理解             若有不懂请戳这里

    


不难发现,如果字符串长度len可以整除next[ len ]的话,循环节长度就等于 len - next[ len ] ,否则循环节长度就等于1。


#include <stdio.h>
#include <string.h>
using namespace std;

const int N = 1e6 + 10;
char a[N];
int nex[N];

void get_nex(int l){
    int i = 0, j = -1;
    nex[0] = -1;
    while(i < l){
        if(j == -1 || a[i] == a[j]){
            i++, j++;
            nex[i] = j;
        }
        else j = nex[j];
    }
}

int main(){
    while(scanf("%s", &a), a[0] != '.'){
        int l = strlen(a);
        get_nex(l);
        if(!(l%(l-nex[l]))) printf("%d\n", l/(l-nex[l]));
        else printf("1\n");
    }
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值