ACM——FatMouse' Trade(贪心)

1 篇文章 0 订阅

FatMouse' Trade

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4803 Accepted Submission(s): 1438
 
Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 
Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
 
Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 
Sample Input
5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1
 
Sample Output
13.333
31.500

题意:
JavaBean
换取最多的JavaBean
学习下面代码的优秀之处。。。。。。。
代码:
/**学习他人代码**/
#include<stdio.h>
#include<vector>///使用容器
#include<algorithm>
#include<iostream>
using namespace std;
struct room{///数据多且有联系的时候,用结构体清楚明了
    int j, f;
      bool operator < (const room t) const{
      return (float)j / f > (float)t.j / t.f;///对于sort函数中的符号重载,能够实现按照j/f的大小顺序排列
    }
};
int main(){
    int m, n, i;
    while(scanf("%d%d", &m, &n) && (m + 1) || (n + 1)){///m,n为-1时结束
        vector<room> v;///定义room类型的vector
        room r;
        double ans = 0;///记住****,计数的一定要初始化为0
        for(i = 0; i < n; ++i){
            scanf("%d%d", &r.j, &r.f);///输入
            v.push_back(r);///放入栈中
        }
        sort(v.begin(), v.end());///排序
    /***贪心算法的实现******/
        i = 0;
        while(m > 0 && i < v.size()){
        if(v[i].f <= m){///当能整间房间换的时候,整间的换
            m -= v[i].f;///换的时候发生变化
            ans += v[i].j;
        }else{
            ans += (double)m / v[i].f * v[i].j;///注意数据类型的变化,处理不好结果很容易不对
            m = 0;///剩下不足一间房的,按比率兑换
        }
            ++i;
        }
    printf("%.3lf\n", ans);///注意输出格式
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值