【HDU1512】【左偏树】Monkey King 题解

Monkey King

Once in a forest, there lived N aggressive monkeys. At the beginning, they each does things in its own way and none of them knows each other. But monkeys can’t avoid quarrelling, and it only happens between two monkeys who does not know each other. And when it happens, both the two monkeys will invite the strongest friend of them, and duel. Of course, after the duel, the two monkeys and all of there friends knows each other, and the quarrel above will no longer happens between these monkeys even if they have ever conflicted.

Assume that every money has a strongness value, which will be reduced to only half of the original after a duel(that is, 10 will be reduced to 5 and 5 will be reduced to 2).

And we also assume that every monkey knows himself. That is, when he is the strongest one in all of his friends, he himself will go to duel.
Input
There are several test cases, and each case consists of two parts.

First part: The first line contains an integer N(N<=100,000), which indicates the number of monkeys. And then N lines follows. There is one number on each line, indicating the strongness value of ith monkey(<=32768).

Second part: The first line contains an integer M(M<=100,000), which indicates there are M conflicts happened. And then M lines follows, each line of which contains two integers x and y, indicating that there is a conflict between the Xth monkey and Yth.

Output
For each of the conflict, output -1 if the two monkeys know each other, otherwise output the strongness value of the strongest monkey in all friends of them after the duel.
Sample Input
5
20
16
10
10
4
5
2 3
3 4
3 5
4 5
1 5
Sample Output
8
5
5
-1
10
左偏树模板题,但是居然Merge最后两行写挂了N遍,调了一天的MLE。

#include <cstdio>
#include <cstring>
#include <algorithm>
#define met(x, y) memset(x, y, sizeof(x))

inline void read( int &res )
{
    char ch = getchar(); res = 0;
    while(ch < '0' || ch > '9') ch = getchar();
    while(ch >= '0' && ch <= '9') res = res * 10 + ch - 48, ch = getchar();
}

const int N = 100005;

int n, m;

int rs[N], ls[N], fa[N], dis[N], str[N];

inline int Merge( int x, int y )
{
    if(!x || !y) return x + y;
    if(str[x] < str[y]) std :: swap(x, y);
    rs[x] = Merge(rs[x], y);
    if(dis[rs[x]] > dis[ls[x]]) std :: swap(ls[x], rs[x]);
    dis[x] = dis[rs[x]] + 1;
    fa[ls[x]] = fa[rs[x]] = x;//GG的地方,这里要注意father的指向,不然乱指MLE。
    fa[x] = x;//为x赋新根
    return x; 
}

inline int Find( int x )
{
    return x == fa[x] ? x : fa[x] = Find(fa[x]);
}

int main()
{
    while(~scanf( "%d", &n ))
    {
        met(ls, 0), met(rs, 0), met(dis, 0);
        dis[0] = -1;
        for(register int i = 1; i <= n; i++)
            read(str[i]), fa[i] = i;
        read(m);
        int x, y;
        while(m--)
        {
            read(x), read(y);
            int fx = Find(x), fy = Find(y);
            if(fx == fy) printf( "-1\n" );
            else
            {
                str[fx] >>= 1;
                str[fy] >>= 1;
                int hp1 = Merge(ls[fx], rs[fx]);
                int hp2 = Merge(ls[fy], rs[fy]);
                ls[fx] = rs[fx] = dis[fx] = 0;
                ls[fy] = rs[fy] = dis[fy] = 0;
                fx = Merge(fx, hp1);
                fy = Merge(fy, hp2);
                int ans = Merge(fx, fy);
                printf( "%d\n", str[ans] );
            }
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值