[BZOJ]3301 [USACO2011 Feb] Cow Line 康托展开&逆康托展开

3301: [USACO2011 Feb] Cow Line

Time Limit: 10 Sec   Memory Limit: 128 MB
Submit: 215   Solved: 108
[ Submit][ Status][ Discuss]

Description

The N (1 <= N <= 20) cows conveniently numbered 1...N are playing 
yet another one of their crazy games with Farmer John. The cows 
will arrange themselves in a line and ask Farmer John what their 
line number is. In return, Farmer John can give them a line number 
and the cows must rearrange themselves into that line. 
A line number is assigned by numbering all the permutations of the 
line in lexicographic order. 

Consider this example: 
Farmer John has 5 cows and gives them the line number of 3. 
The permutations of the line in ascending lexicographic order: 
1st: 1 2 3 4 5 
2nd: 1 2 3 5 4 
3rd: 1 2 4 3 5 
Therefore, the cows will line themselves in the cow line 1 2 4 3 5. 

The cows, in return, line themselves in the configuration "1 2 5 3 4" and 
ask Farmer John what their line number is. 

Continuing with the list: 
4th : 1 2 4 5 3 
5th : 1 2 5 3 4 
Farmer John can see the answer here is 5 

Farmer John and the cows would like your help to play their game. 
They have K (1 <= K <= 10,000) queries that they need help with. 
Query i has two parts: C_i will be the command, which is either 'P' 
or 'Q'. 

If C_i is 'P', then the second part of the query will be one integer 
A_i (1 <= A_i <= N!), which is a line number. This is Farmer John 
challenging the cows to line up in the correct cow line. 

If C_i is 'Q', then the second part of the query will be N distinct 
integers B_ij (1 <= B_ij <= N). This will denote a cow line. These are the 
cows challenging Farmer John to find their line number. 

有N头牛,分别用1……N表示,排成一行。 
将N头牛,所有可能的排列方式,按字典顺序从小到大排列起来。 
例如:有5头牛 
1st: 1 2 3 4 5 
2nd: 1 2 3 5 4 
3rd: 1 2 4 3 5 
4th : 1 2 4 5 3 
5th : 1 2 5 3 4 
…… 
现在,已知N头牛的排列方式,求这种排列方式的行号。 
或者已知行号,求牛的排列方式。 
所谓行号,是指在N头牛所有可能排列方式,按字典顺序从大到小排列后,某一特定排列方式所在行的编号。 
如果,行号是3,则排列方式为1 2 4 3 5 
如果,排列方式是 1 2 5 3 4 则行号为5 

有K次问答,第i次问答的类型,由C_i来指明,C_i要么是‘P’要么是‘Q’。 
当C_i为P时,将提供行号,让你答牛的排列方式。当C_i为Q时,将告诉你牛的排列方式,让你答行号。 

Input

* Line 1: Two space-separated integers: N and K 
* Lines 2..2*K+1: Line 2*i and 2*i+1 will contain a single query. 
Line 2*i will contain just one character: 'Q' if the cows are lining 
up and asking Farmer John for their line number or 'P' if Farmer 
John gives the cows a line number. 

If the line 2*i is 'Q', then line 2*i+1 will contain N space-separated 
integers B_ij which represent the cow line. If the line 2*i is 'P', 
then line 2*i+1 will contain a single integer A_i which is the line 
number to solve for. 

第1行:N和K 
第2至2*K+1行:Line2*i ,一个字符‘P’或‘Q’,指明类型。 
如果Line2*i是P,则Line2*i+1,是一个整数,表示行号; 
如果Line2*i+1 是Q ,则Line2+i,是N个空格隔开的整数,表示牛的排列方式。

Output

* Lines 1..K: Line i will contain the answer to query i. 

If line 2*i of the input was 'Q', then this line will contain a 
single integer, which is the line number of the cow line in line 
2*i+1. 

If line 2*i of the input was 'P', then this line will contain N 
space separated integers giving the cow line of the number in line 
2*i+1. 
第1至K行:如果输入Line2*i 是P,则输出牛的排列方式;如果输入Line2*i是Q,则输出行号

Sample Input

5 2
P
3
Q
1 2 5 3 4

Sample Output


1 2 4 3 5
5

HINT

Source

[ Submit][ Status][ Discuss]


HOME Back

  今天学习了一发康托展开, 很简单也很精妙, 用一种变进制的思想恰好对应了排列, 而且还可以倒推回来...

  这道题就是裸的康托展开啦.

#include<bits/stdc++.h>
#define clear(a) memset(a, 0, sizeof(a))
using namespace std;
char ss[2];
int n, K;
long long rank, pw[22];
int id[22], a[22], vis[22];
inline void ExCantor() {
	long long ans = 0;
	for (int i = 1; i <= n; ++ i)
		scanf("%d", &a[i]);
	for (int i = 1; i <= n; ++ i) {
		int cnt = 0;
		for (int j = i + 1; j <= n; ++ j)
			if (a[j] < a[i]) cnt ++;
		ans += cnt * pw[n - i];
	}
	printf("%lld\n", ++ ans);
}
inline void IExcantor() {
	clear(vis);
	scanf("%lld", &rank);
	rank --;
	for (int i = 1; i <= n; ++ i) {
		int t = rank / pw[n - i];
		rank %= pw[n - i];
		for (int j = 1; j <= n; ++ j)
			if (!vis[j]) {
				if (!t) {id[i] = j; vis[j] = true; break;}
				t --;
			}
	}
	for (int i = 1; i < n; ++ i)
		printf("%d ", id[i]);
	printf("%d\n", id[n]);
}
int main() {
	scanf("%d%d", &n, &K);
	pw[0] = 1;
	for (int i = 1; i <= n; ++ i) pw[i] = pw[i - 1] * i;
	for (int i = 1; i <= K; ++ i) {
		scanf("%s", ss);
		if (ss[0] == 'P') IExcantor();
		else ExCantor();
	}
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值