POJ_1840Eqs解题报告

Eqs
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 7687 Accepted: 3750

Description

Consider equations having the following form: 
a1x1 3+ a2x2 3+ a3x3 3+ a4x4 3+ a5x5 3=0 
The coefficients are given integers from the interval [-50,50]. 
It is consider a solution a system (x1, x2, x3, x4, x5) that verifies the equation, xi∈[-50,50], xi != 0, any i∈{1,2,3,4,5}. 

Determine how many solutions satisfy the given equation. 

Input

The only line of input contains the 5 coefficients a1, a2, a3, a4, a5, separated by blanks.

Output

The output will contain on the first line the number of the solutions for the given equation.

Sample Input

37 29 41 43 47

Sample Output

654
题目连接:http://poj.org/problem?id=1840
算法类型:hash&&枚举
解题思路:先枚举前三个数的所有值,利用hash散列表分散到一个大数组里,在枚举后2个数的所有值,在和前3个数的所有值相对应,找出所有解。
算法实现:
#include<stdio.h>
#include<string.h>
#define MAX 37500001   //一个很大的质数,大于5个数解的最大值;
char hash[MAX];
int a[6];
void search()
{
	int i,j,k,w,q,s,sum=0;
	memset(hash,0,sizeof(hash));
	for(i=-50;i<=50;i++)    //枚举前3个;
	{
		for(j=-50;j<=50;j++)
		{
			for(k=-50;k<=50;k++)
			{
                           if(i!=0&&j!=0&&k!=0)
			   {
				   s=a[1]*i*i*i+a[2]*j*j*j+a[3]*k*k*k;
				   s=s+MAX;
				   s=s%MAX;
				   hash[s]++;        //储存有多少个相同的数;
			   }
			}
		}
	}
	for(q=-50;q<=50;q++)    //枚举后2个;
	{
		for(w=-50;w<=50;w++)
		{
			if(q!=0&&w!=0)
			{
				s=-a[4]*q*q*q-a[5]*w*w*w;      
				s=s+MAX;                     //hash,相反数模大质数的方法;
				sum=sum+hash[s%MAX];
			}
		}
	}
    printf("%d\n",sum);
}
int main()
{
	int i;
	for(i=1;i<=5;i++)
	{
		scanf("%d",&a[i]);
	}
	search();
	return 0;
}



  • 6
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值