A - Biscuit Generator

Time Limit: 2 sec / Memory Limit: 1024 MB
Score : 100points

Problem Statement
A biscuit making machine produces B biscuits at the following moments: A seconds, 2A seconds, 3A seconds and each subsequent multiple of A seconds after activation.

Find the total number of biscuits produced within T+0.5 seconds after activation.

Constraints
All values in input are integers.1≤A,B,T≤20.
Input
Input is given from Standard Input in the following format:
A B T
Output
Print the total number of biscuits produced within T+0.5 seconds after activation.

Sample Input 1
3 5 7
Sample Output 1
Copy
10
Five biscuits will be produced three seconds after activation.
Another five biscuits will be produced six seconds after activation.
Thus, a total of ten biscuits will be produced within 7.5 seconds after activation.

Sample Input 2
3 2 9
Sample Output 2
6

Sample Input 3
20 20 19
Sample Output 3
0

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<string>
#include<ctime>
#include<cmath>
#include<iostream>
#include<algorithm>
#include<map>
#include<stack>
#include<queue>
#include<set>
#include<vector>
#define ll long long
#define dd double
using namespace std;

int main() {
	dd n, m, k;
	while (cin >> n >> m >> k) {
		dd sum = 0;
		dd p = n;
		while (n <= (k + 0.5)) {
			sum += m;
			n += p;
		}
		cout << sum << endl;
	}
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值