Anniversary party【 POJ - 2342 】

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0

Output

Output should contain the maximal sum of guests' ratings.

Sample Input

7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

Sample Output

5

题解:

有n名员工参加聚会,如果某个员工和他的上司一同参加聚会,那么他欢乐度会变成0,

输入若干数据(L,K)L的上司是K。

问最大欢乐度的和为多少。

因此我们可以用树上dp+dfs,用dfs找树的关系,

dp用来尝试每个节点是去还是不去。以此找到最大和。

代码:

#include<string.h>
#include<stdio.h>
#include<algorithm>
using namespace std;

int n,a,b;
int sum;
int dp[6100][11],f[6100];
bool v[6100],book[6100];

void dfs(int d)
{
	v[d]=true;
	for(int i=1;i<=n;i++)
	{
		if(!v[i]&&f[i]==d)
		{
			dfs(i);
			dp[d][0]+=max(dp[i][0],dp[i][1]);//上司去
			dp[d][1]+=dp[i][0];//上司不去
		}
	}
}

int main()
{
	scanf("%d",&n);
	for(int i=1;i<=n;i++)
	  scanf("%d",&dp[i][1]);//每个人的欢乐度
	while(~scanf("%d%d",&a,&b))
	{
		if(a==0 && b==0)//结束条件
		   break;
		f[a]=b;
		book[a]=true;
	}
	for(int i=1;i<=n;i++)
	{
		if(!book[i])
		   sum=i;//记录任意一个上司的
	}
	dfs(sum);
	printf("%d\n",max(dp[sum][0],dp[sum][1]));
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值