Michael_J's Zone

学海无涯

ubuntu下如何查看软件安装目录以及安装版本

1.查询版本

1)aptitude show 软件名

例如:aptitude show kde-runtime 

显示如下:

****@ubuntu:~$ aptitude show kde-runtime
软件包: kde-runtime             
状态: 未安装
版本号: 4:4.8.1-0ubuntu1
优先级: 可选
部分: kde
维护者: Kubuntu Developers <kubuntu-devel@lists.ubuntu.com>
未压缩尺寸: 9,607 k
依赖于: libasound2 (>= 1.0.23), libattica0.3 (>= 0.3.0), libc6 (>= 2.15),
           libcanberra0 (>= 0.2), libexiv2-11, libgcc1 (>= 1:4.1.1), libjpeg8
           (>= 8c), libkcmutils4 (>= 4:4.8.1), libkdeclarative5 (>= 4:4.7.0),
           libkdecore5 (>= 4:4.8.1), libkdesu5 (>= 4:4.8.1), libkdeui5 (>=
           4:4.8.1), libkdewebkit5 (>= 4:4.8.1), libkdnssd4 (>= 4:4.8.1),
           libkemoticons4 (>= 4:4.8.1), libkfile4 (>= 4:4.8.1), libkhtml5 (>=
           4:4.8.1), libkidletime4 (>= 4:4.8.1), libkio5 (>= 4:4.8.1),
           libkmediaplayer4 (>= 4:4.8.1), libknewstuff3-4 (>= 4:4.8.1),
           libknotifyconfig4 (>= 4:4.8.1), libkparts4 (>= 4:4.8.1), libkpty4 (>=
           4:4.8.1), libnepomuk4 (>= 4:4.8.1), libnepomukdatamanagement4 (>=
           4:4.8.1), libnepomukquery4a (>= 4:4.8.1), libnepomuksync4 (>=
           4:4.8.1), libntrack-qt4-1 (>= 005), libopenexr6 (>= 1.6.1),
           libphonon4 (>= 4:4.7.0really4.5.0), libplasma3 (>= 4:4.8.1),
           libpulse-mainloop-glib0 (>= 1:0.99.1), libpulse0 (>= 1:0.99.1),
           libqt4-dbus (>= 4:4.6.1), libqt4-declarative (>= 4:4.7.0~rc1),
           libqt4-network (>= 4:4.5.3), libqt4-script (>= 4:4.6.1), libqt4-svg
           (>= 4:4.5.3), libqt4-xml (>= 4:4.5.3), libqtcore4 (>= 4:4.8.0),
           libqtgui4 (>= 4:4.8.0), libqtwebkit4 (>= 2.2~2011week36),
           libsmbclient (>= 2:3.2.0), libsolid4 (>= 4:4.8.1), libsoprano4 (>=
           2.6.51), libssh-4 (>= 0.3.91), libstdc++6 (>= 4.6),
           libstreamanalyzer0 (>= 0.7.7), libstreams0 (>= 0.7.7), libx11-6,
           libxcursor1 (> 1.1.2), phonon, perl, kde-runtime-data (>=
           4:4.8.1-0ubuntu1), kdelibs5-plugins (>= 4:4.8.1), oxygen-icon-theme
           (>= 4:4.6), shared-desktop-ontologies, plasma-scriptengine-javascript
           (= 4:4.8.1-0ubuntu1)
推荐: udisks, upower, virtuoso-minimal, kubuntu-debug-installer, icoutils,
        libcanberra-pulse | libcanberra-gstreamer
建议: djvulibre-bin, finger
冲突: kdelibs4-dev
破坏: kdebase-runtime (< 4:4.6.80), kdebase-runtime-bin-kde4,
        kdebase-runtime-data (< 4:4.4.80), kdebase-workspace-bin (< 4:4.6),
        kdebluetooth (< 1.0~beta7-1), kdelibs5 (< 4:4.4.80), kdelibs5-plugins (<
        4:4.5), nepomukcontroller, plasma-netbook (< 4:4.5.95),
        plasma-scriptengine-declarative, plasma-scriptengine-javascript (<
        4:4.6.80)
代替: kdebase-runtime (< 4:4.6.80), kdebase-runtime-bin-kde4,
        kdebase-runtime-data (< 4:4.4.80), kdebase-workspace-bin (< 4:4.6),
        kdebluetooth (< 1.0~beta7-1), kdelibs5 (< 4:4.4.80), kdelibs5-plugins (<
        4:4.5), nepomukcontroller, plasma-netbook (< 4:4.5.95),
        plasma-scriptengine-declarative, plasma-scriptengine-javascript (<
        4:4.6.80)
描述: runtime components from the official KDE release
 KDE is produced by an international technology team that creates free and open
 source software for desktop and portable computing. Among KDE's products are a
 modern desktop system for Linux and UNIX platforms, comprehensive office
 productivity and groupware suites and hundreds of software titles in many
 categories including Internet and web applications, multimedia, entertainment,
 educational, graphics and software development. 
 
 This package contains programs and data needed at runtime by KDE applications.
主页: http://www.kde.org/


2)dpkg -l软件名

 例如:dpkg -l gedit 

*****@ubuntu:~$ dpkg -l gedit
期望状态=未知(u)/安装(i)/删除(r)/清除(p)/保持(h)
| 状态=未安装(n)/已安装(i)/仅存配置(c)/仅解压缩(U)/配置失败(F)/不完全安装(H)/触发器等待(W)/触发器未决(T)
|/ 错误?=(无)/须重装(R) (状态,错误:大写=故障)
||/ 名称         版本         描述
+++-==============-==============-============================================
ii  gedit          3.3.8-0ubuntu1 official text editor of the GNOME desktop en


2.查询安装路径

1)dpkg -L 软件名

例如:dpkg -L gedit  

*****@ubuntu:~$ dpkg -L gedit
/.
/usr
/usr/bin
/usr/bin/gedit
/usr/share
/usr/share/applications
/usr/share/applications/gedit.desktop
/usr/share/dbus-1
/usr/share/dbus-1/services
/usr/share/dbus-1/services/org.gnome.gedit.service
/usr/share/bug
/usr/share/bug/gedit
/usr/share/bug/gedit/script
/usr/share/pyshared
/usr/share/pyshared/gi
/usr/share/pyshared/gi/overrides
/usr/share/pyshared/gi/overrides/Gedit.py
/usr/share/gedit
/usr/share/gedit/gedit-bugreport
/usr/share/lintian
/usr/share/lintian/overrides
/usr/share/lintian/overrides/gedit
/usr/share/menu
/usr/share/menu/gedit
/usr/share/doc
/usr/share/doc/gedit
/usr/share/doc/gedit/README
/usr/share/doc/gedit/BUGS
/usr/share/doc/gedit/copyright
/usr/share/doc/gedit/NEWS.gz
/usr/share/doc/gedit/AUTHORS
/usr/share/doc/gedit/changelog.Debian.gz
/usr/share/python
/usr/share/python/runtime.d
/usr/share/python/runtime.d/gedit.rtupdate
/usr/lib
/usr/lib/gedit
/usr/lib/gedit/girepository-1.0
/usr/lib/gedit/girepository-1.0/Gedit-3.0.typelib
/usr/lib/gedit/plugins
/usr/lib/gedit/plugins/libmodelines.so
/usr/lib/gedit/plugins/zeitgeist.plugin
/usr/lib/gedit/plugins/time.plugin
/usr/lib/gedit/plugins/libspell.so
/usr/lib/gedit/plugins/libtime.so
/usr/lib/gedit/plugins/quickopen.plugin
/usr/lib/gedit/plugins/libsort.so
/usr/lib/gedit/plugins/externaltools
/usr/lib/gedit/plugins/externaltools/outputpanel.py
/usr/lib/gedit/plugins/externaltools/windowactivatable.py
/usr/lib/gedit/plugins/externaltools/manager.py
/usr/lib/gedit/plugins/externaltools/capture.py
/usr/lib/gedit/plugins/externaltools/library.py
/usr/lib/gedit/plugins/externaltools/filelookup.py
/usr/lib/gedit/plugins/externaltools/__init__.py
/usr/lib/gedit/plugins/externaltools/functions.py
/usr/lib/gedit/plugins/externaltools/linkparsing.py
/usr/lib/gedit/plugins/pythonconsole.plugin
/usr/lib/gedit/plugins/docinfo.plugin
/usr/lib/gedit/plugins/changecase.plugin
/usr/lib/gedit/plugins/modelines.plugin
/usr/lib/gedit/plugins/snippets
/usr/lib/gedit/plugins/snippets/placeholder.py
/usr/lib/gedit/plugins/snippets/shareddata.py
/usr/lib/gedit/plugins/snippets/substitutionparser.py
/usr/lib/gedit/plugins/snippets/snippet.py
/usr/lib/gedit/plugins/snippets/completion.py
/usr/lib/gedit/plugins/snippets/exporter.py
/usr/lib/gedit/plugins/snippets/singleton.py
/usr/lib/gedit/plugins/snippets/windowactivatable.py
/usr/lib/gedit/plugins/snippets/document.py
/usr/lib/gedit/plugins/snippets/appactivatable.py
/usr/lib/gedit/plugins/snippets/languagemanager.py
/usr/lib/gedit/plugins/snippets/importer.py
/usr/lib/gedit/plugins/snippets/manager.py
/usr/lib/gedit/plugins/snippets/library.py
/usr/lib/gedit/plugins/snippets/signals.py
/usr/lib/gedit/plugins/snippets/__init__.py
/usr/lib/gedit/plugins/snippets/helper.py
/usr/lib/gedit/plugins/snippets/parser.py
/usr/lib/gedit/plugins/sort.plugin
/usr/lib/gedit/plugins/externaltools.plugin
/usr/lib/gedit/plugins/spell.plugin
/usr/lib/gedit/plugins/quickopen
/usr/lib/gedit/plugins/quickopen/popup.py
/usr/lib/gedit/plugins/quickopen/__init__.py
/usr/lib/gedit/plugins/quickopen/virtualdirs.py
/usr/lib/gedit/plugins/libchangecase.so
/usr/lib/gedit/plugins/filebrowser.plugin
/usr/lib/gedit/plugins/pythonconsole
/usr/lib/gedit/plugins/pythonconsole/__init__.py
/usr/lib/gedit/plugins/pythonconsole/console.py
/usr/lib/gedit/plugins/pythonconsole/config.py
/usr/lib/gedit/plugins/snippets.plugin
/usr/lib/gedit/plugins/libdocinfo.so
/usr/lib/gedit/plugins/libzeitgeistplugin.so
/usr/lib/gedit/plugins/libfilebrowser.so
/usr/lib/python2.7
/usr/lib/python2.7/dist-packages
/usr/lib/python2.7/dist-packages/gi
/usr/lib/python2.7/dist-packages/gi/overrides
/usr/lib/libgedit-private.so.0.0.0
/usr/lib/libgedit-private.so.0
/usr/lib/python2.7/dist-packages/gi/overrides/Gedit.py

或者

2)whereis 软件名

例如:whereis gedit

阅读更多
个人分类: Ubuntu
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

不良信息举报

ubuntu下如何查看软件安装目录以及安装版本

最多只允许输入30个字

加入CSDN,享受更精准的内容推荐,与500万程序员共同成长!
关闭
关闭