【UVA】【DP】【第五章】【第一题】 History Grading

Background

Many problems in Computer Science involve maximizing some measureaccording to constraints.

Consider a history exam in which students are asked to put severalhistorical events into chronological order. Students who order all theevents correctly will receive full credit, but how should partial creditbe awarded to students who incorrectly rank one or more of thehistorical events?

Some possibilities for partial credit include:

  1. 1 point for each event whose rank matches its correct rank
  2. 1 point for each event in the longest (not necessarily contiguous)sequence of events which are in the correct order relative to each other.

For example, if four events are correctly ordered 1 2 3 4 then theorder 1 3 2 4 would receive a score of 2 using the first method (events1 and 4 are correctly ranked) and a score of 3 using the second method(event sequences 1 2 4 and 1 3 4 are both in the correct order relativeto each other).

In this problem you are asked to write a program to score such questionsusing the second method.

The Problem

Given the correct chronological order of n events tex2html_wrap_inline34 astex2html_wrap_inline36 wheretex2html_wrap_inline38 denotes the ranking ofeventi in the correct chronological order and a sequence of studentresponses tex2html_wrap_inline42 wheretex2html_wrap_inline44 denotes thechronological rank given by the student to eventi; determine the length of the longest (not necessarily contiguous) sequenceof events in the student responses that are in the correct chronologicalorder relative to each other.

The Input

The first line of the input will consist of one integer n indicatingthe number of events withtex2html_wrap_inline50 . The second line willcontainn integers, indicating the correct chronological order of nevents. The remaining lines will each consist ofn integers with eachline representing a student's chronological ordering of the n events.All lines will containn numbers in the range tex2html_wrap_inline60 , with each numberappearing exactly once per line, and with each number separated fromother numbers on the same line by one or more spaces.

The Output

For each student ranking of events your program should print the scorefor that ranking. There should be one line of output for each studentranking.

Sample Input 1

4
4 2 3 1
1 3 2 4
3 2 1 4
2 3 4 1

Sample Output 1

1
2
3

Sample Input 2

10
3 1 2 4 9 5 10 6 8 7
1 2 3 4 5 6 7 8 9 10
4 7 2 3 10 6 9 1 5 8
3 1 2 4 9 5 10 6 8 7
2 10 1 3 8 4 9 5 7 6

Sample Output 2

6
5
10
9


英文题必有其牛逼之处

比如这道题的输入数据无比奇葩

对多组数据吐槽不能……

后来不想写了就 写了个对付单组数据的

多组数据只需要读S【1】 然后再读S【2】到S【N】

我没有写

这里贴单组数据的代码

这道题比较巧妙啦

各种转化 转换

要做出来 首先英语必须牛逼 其次思维一定不能混乱 否则…………

不多说 贴代码 这道题主要就是对题意的理解

读懂题后就只是求一个最长不下降非连续序列而已

代码如下

#include <cstdlib>
#include <cstdio>
#include <iomanip>
#include <cstring>
#include <algorithm>
#define max(a, b) (a > b ? a : b)

int N;
int F[50];
int A[50];
int S[50];
int Ord[50];

void init_file()
{
  freopen("White_DP_1.in", "r", stdin);
  freopen("White_DP_1.out", "w", stdout);
}

void read_data()
{
  scanf("%d", &N);
  for(int i = 1; i <= N; i++)
  {
	  int x;
      scanf("%d", &x);
	  A[x] = i;
  }
  for(int i = 1; i <= N; i++)
  {
    Ord[A[i]] = i;
  }
}

void work()
{
	for(int i = 1; i <= N; i++)
	{
	  int x;
	  scanf("%d", &x);
	  S[x] = i;
	}
	for(int i = 1; i <= N; i++)
	{
	  S[i] = Ord[S[i]];
	}
	for(int i = N; i >= 1; i--)
	{
	  F[i] = 1;
	}
	for(int i = N; i >= 1; i--)
	{
	  int Max = -1;
	  for(int j = i; j <= N; j++)
	  {
		  if (S[j] > S[i])
		  {
		    Max = max(Max, F[j]);
		  }
	  }
	  if (Max != -1)
	  F[i] += Max;
	}
	printf("%d", F[1]);
}

int main()
{
  init_file();
  read_data();
  work();
  return 0;
}  


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值