天梯赛 L2-012 关于堆的判断 (25 分) 模拟堆

天梯赛 L2-012 关于堆的判断 (25 分)


题目

将一系列给定数字顺序插入一个初始为空的小顶堆H[]。随后判断一系列相关命题是否为真。命题分下列几种:

  • x is the rootx是根结点;
  • x and y are siblingsxy是兄弟结点;
  • x is the parent of yxy的父结点;
  • x is a child of yxy的一个子结点。

输入格式

每组测试第1行包含2个正整数N ( ≤ 1000 ) (≤ 1000) 1000M ( ≤ 20 ) (≤ 20) 20,分别是插入元素的个数、以及需要判断的命题数。下一行给出区间 [ − 10000 , 10000 ] [−10000,10000] [10000,10000]内的N个要被插入一个初始为空的小顶堆的整数。之后M行,每行给出一个命题。题目保证命题中的结点键值都是存在的。

输出格式:

对输入的每个命题,如果其为真,则在一行中输出T,否则输出F

测试样例

输入样例:

5 4
46 23 26 24 10
24 is the root
26 and 23 are siblings
46 is the parent of 23
23 is a child of 10

输出样例:

F
T
F
T

简单分析:

就是一个手动模拟堆的过程,调用priority_queue是解决不了的= =
建堆的时候是执行up操作,不能用down操作。
还要记录一下下标的位置,使用集合存储,方便查询时候输出。
就是查询的时候字符串处理比较麻烦。

代码

#include <iostream>
#include <algorithm>
#include <unordered_map>

using namespace std;

const int N = 10010;

int n, m;
int h[N], cnt;

void up(int u) {
	while (u >> 1 && h[u] < h[u >> 1]) {
		swap(h[u], h[u >> 1]);
		u >>= 1;
	}
}

int main() {
	cin >> n >> m;
	for (int i = 1; i <= n; i++) {
		int x;
		cin >> x;
		h[++cnt] = x;
		up(i);
	}

	unordered_map<int, int> mp;
	for (int i = 1; i <= n; i++) mp[h[i]] = i;

	while (m--) {
		int a;
		cin >> a;
		string s1;
		cin >> s1;
		if (s1 == "and") {
			int b;
			cin >> b;
			cin >> s1 >> s1;
			if (mp[a] / 2 == mp[b] / 2) puts("T");
			else puts("F");
		}
		else {
			cin >> s1;
			if (s1 == "a") {
				cin >> s1 >> s1;
				int b;
				cin >> b;
				if (mp[a] / 2 == mp[b]) puts("T");
				else puts("F");
			}
			else {
				cin >> s1;
				if (s1 == "root") {
					if (a == h[1]) puts("T");
					else puts("F");
				}
				else {
					cin >> s1;
					int b;
					cin >> b;
					if (mp[b] / 2 == mp[a]) puts("T");
					else puts("F");
				}
			}
		}
	}

	return 0;
}

感悟与收获

这里建堆操作只能使用up。

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值