PAT (Advanced Level) Practice 1002 A+B for Polynomials

PAT (Advanced Level) Practice 1002 A+B for Polynomials


Topic Description:

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
K N 1 a N 1 N 2 a N 2   . . .   N K a N k K N_1 a_{N_1} N_2 a_{N_2} \ ... \ N_K a_{N_k} KN1aN1N2aN2 ... NKaNk
where K K K is the number of nonzero terms in the polynomial, N i N_i Ni and a N i ( i = 1 , 2 , ⋯ , K ) a_{N_i}(i=1,2,⋯,K) aNi(i=1,2,,K) are the exponents and coefficients, respectively. It is given that 1 ≤ K ≤ 10 , 0 ≤ N K < ⋯ < N 2 < N 1 ≤ 1000. 1≤K≤10,0≤N_K <⋯<N_2<N_1≤1000. 1K100NK<<N2<N11000.

Output Specification:

For each test case you should output the sum of A A A and B B B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Test:

Sample Input1:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output1:

3 2 1.5 1 2.9 0 3.2

Simple analysis:

  • None

My codes:

#include <iostream>

using namespace std;

const int N = 1010;

float c[N];

int main() {
	int k;
	int ex;
	float co;
	scanf("%d", &k);
	for (int i = 0; i < k; i ++){
		scanf("%d%f", &ex, &co);
		c[ex] += co;
	}
	scanf("%d", &k);
	for (int i = 0; i < k; i++) {
		scanf("%d%f", &ex, &co);
		c[ex] += co;
	}
	
	int cnt = 0;
	for (int i = 0; i < N; i++) {
		if (c[i] != 0) cnt++;
	}
	printf("%d", cnt);
	for (int i = N; i >= 0; i--) {
		if (c[i] != 0.0)
			printf(" %d %.1f", i, c[i]);
	}
	
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值