PAT (Advanced Level) Practice 1001 A+B Format

PAT (Advanced Level) Practice 1001 A+B Format


Topic Description:

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a a a and b b b where − 1 0 6 ≤ a −10^6≤a 106a, b ≤ 1 0 6 b≤10^6 b106. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Test:

Sample Input1:

-1000000 9

Sample Output1:

-999,991

Simple analysis:

  • 简单的字符串/数字处理问题

My codes:

#include <iostream>
#include <cmath>
#include <vector>

using namespace std;

int main() {
	int a, b, c;
	cin >> a >> b;
	
	c = a + b;
	bool flag = false;
	if (c < 0) {
		flag = true;
		c = abs(c);
	}
	
	vector<int> ve;
	while (c / 1000) {
		int d = c % 1000;
		ve.push_back(d);
		c /= 1000;
	}
	
	if (flag) cout << '-';
	cout << c;
	for (int i = ve.size() - 1; i >= 0; i --) {
		cout << ',';
		printf("%03d", ve[i]);
	}
    cout << endl;
	
	return 0;
}

Thinking

  • 今天开始好好刷PTA甲级,提高编程水平= v =
  • (快大四的菜鸡了)希望任何时候努力都不晚
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值