PAT --- 1007.Maximum Subsequence Sum (25 分)

1007 Maximum Subsequence Sum (25 分)

Given a sequence of KKK integers { N1N_1N1, N2N_2N2, ..., NKN_KNK }. A continuous subsequence is defined to be { NiN_iNi, Ni+1N_{i+1}Ni+1, ..., NjN_jNj } where 1≤i≤j≤K1 \le i \le j \le K1ijK. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer KKK (≤10000\le 1000010000). The second line contains KKK numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices iii and jjj (as shown by the sample case). If all the KKK numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

思路

难点在于如何得到,最大值的区间下标。
分析:sum为要求的最⼤大和,temp为临时最⼤大和,leftindex和rightindex为所求的⼦子序列列的下标,tempindex标记left的临时下标~
temp = temp + v[i],当temp⽐比sum⼤大,就更更新sum的值、leftindex和rightindex的值;当temp < 0,那么后⾯面不不管来什什么值,都应该舍弃temp < 0前⾯面的内容,因为负数对于总和只可能拉低总和,不不可能增加总和,还不不如舍弃~
舍弃后,直接令temp = 0,并且同时更更新left的临时值tempindex。因为对于所有的值都为负数的情况要输出0,第⼀一个值,最后⼀一个值,所以在输⼊入的时候⽤用flag判断是不不是所有的数字都是⼩小于0的,如果是,要在输⼊入的时候特殊处理理~

代码

#include <iostream>
#include <vector>
#include <string>
using namespace std;

int main() {
	int k;
	cin >> k;
	vector<int> v(k); 
	int leftInd = 0, rightInd = k - 1, sum = -1, temp = 0, tempInd = 0;
	for (int i = 0; i < k; i++) {
		cin >> v[i];
		temp += v[i];
		if (temp < 0) {
			temp = 0; 
			tempInd = i + 1;
		}
		else if (temp > sum) {
			sum = temp;
			leftInd = tempInd;
			rightInd = i;
		}
	}
	if (sum < 0)	sum = 0;
	printf("%d %d %d", sum, v[leftInd], v[rightInd]);
	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值