1007 Maximum Subsequence Sum (25)(25 分)

目录

题目:

分析: 

反思:

代码:


题目:

Given a sequence of K integers { N~1~, N~2~, ..., N~K~ }. A continuous subsequence is defined to be { N~i~, N~i+1~, ..., N~j~ } where 1 <= i <= j <= K. TheMaximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

分析: 

最大子列和问题,算法移步:https://blog.csdn.net/Watson_R/article/details/81110150

反思:

需要考虑的情况有:

1、输入输出:样例 (存在多种最大子列和,取下标小的)

2、输入:3 -1 -2 -3 输出:0 -1 -3(当全部为负数的时候)

3、输入:3 0 1 0 输出:1 0 1(当前后有0的时候取前不取后)

4、输入:1 0 输出:0 0 0 (只有一个元素)

5、输入:3 -1 0 -1 输出:0 1 1 (只有一个非负数)

代码:

#include<iostream>
#include<iomanip>
#include<functional>
#include<algorithm>
#include<vector>
#include<queue>
#include<string>
#include<map>
#include<list>
#include<set>
using namespace std;
int main()
{
	vector<int> que, max, end;//que表示原数列,max表示从该位置起最大的子数列和, end表示max子数列结束的下标
	int n, i = 0, index, sum = -1, num;
	cin >> n;
	index = n - 1;
	for (i = 0; i < n; i++)
	{
		cin >> num;
		que.push_back(num);
		if (sum < num) {sum = num; index = i;}
		end.push_back(i);
	}
	if (sum >= 0)//若非全负
	{
		while (*que.rbegin() < 0)que.pop_back();//删除末尾为负的数
		max = que;
		for (i = que.size() - 1; i > 0; i--)
		{
			if (max[i - 1] < max[i] + que[i - 1])//如果左数<右侧最大子列和+该数
			{
				max[i - 1] = max[i] + que[i - 1];//更新以该位置为起点的最大子列和
				end[i - 1] = end[i];//更新该位置最大子列和结束元素的下标
			}
			if (max[i - 1] >= sum) { sum = max[i - 1]; index = i - 1; }
		}
		cout << sum << ' ' << que[index] << ' ' << que[end[index]];
	}
	else cout << 0 << ' ' << que[0] << ' ' << *que.rbegin(); 
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值