hdu1017_____A Mathematical Curiosity

Problem Description

Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.
This problem contains multiple test cases!
The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.
The output format consists of N output blocks. There is a blank line between output blocks.

Input

You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.

Output

For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.

Sample Input

1

 

10 1

20 3

30 4

0 0

Sample Output

Case 1: 2

Case 2: 4

Case 3: 5

题意:先输入一个整数表示测试的次数,然后每组测试中输入n和m,在0 < a < b < n 范围中,找出满足 (a^2+b^2 +m)/(ab)的个数,并按要求输出,其中每组测试中要加额外的换行符。

思路:

1.输入一个N,表示测试的组数

2.每组中只有当n和m为0 0 时表示该组输入的结束

3.判断符合(a^2+b^2 +m)/(ab)是一个整数的条件的转换((a^2+b^2 +m)%(ab)==0)

4.当一组输入结束后还有下一组是输出一个换行符

代码如下:

#include<cstdio>

using namespace std;

int main()
{
    int N;
    scanf("%d",&N);
    while(N--)
    {
        int n,m,res,t=1;
        while(scanf("%d%d",&n,&m))
        {
            res=0;
            if(n==0&&m==0)
                break;
            for(int i=1;i<n;i++)
            {
                for(int j=i+1;j<n;j++)
                {
                    if((i*i+j*j+m)%(i*j)==0)
                        res++;
                }
            }
            printf("Case %d: %d\n",t,res);
            t++;
        }
        if(N)
            printf("\n");
    }
    return 0;
}

 

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值