【HD 1222】Wolf and Rabbit

32 篇文章 0 订阅
1 篇文章 0 订阅

第一下看到的时候懵了,想了半天才明白个大概为什么是GCD。

Wolf and Rabbit

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7349 Accepted Submission(s): 3678

Problem Description
There is a hill with n holes around. The holes are signed from 0 to n-1.

A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes.

Input
The input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n( 0 < m,n<2147483648).

Output
For each input m n, if safe holes exist, you should output “YES”, else output “NO” in a single line.

Sample Input
2
1 2
2 2

Sample Output
NO
YES

Author
weigang Lee

Source
杭州电子科技大学第三届程序设计大赛

——————————————————————————————————
思路: m个洞,每隔n个进一次。
m/n …… a
( a+m )/n ……. b
( b+m )/n ……. c
相当于是在交错的走,如果没有一点使得和前面的轨迹重合的话所有洞都会走一遍,所以,就是看是不是有GCD
——————————————————————————————————

#include<cstdio>
int gcd( int a,int b )
{
    if( a%b == 0) return b;
    else return gcd( b,a%b );
}



int main()
{
    int x,y,t;
    scanf("%d",&t);
    while( t-- )
    {
        scanf("%d%d",&x,&y);
        if( gcd(x,y) != 1 )
        {
            printf("YES\n");    
        }
        else 
            printf("NO\n");
    }


}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值