hdu_1222_欧几里得_gcd简单应用_欧几里得扩展性质

Wolf and Rabbit

There is a hill with n holes around. The holes are signed from 0 to n-1.

A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes.
Input
The input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n;
Output
For each input m n, if safe holes exist, you should output “YES”, else output “NO” in a single line.
Sample Input
2
1 2
2 2
Sample Output
NO
YES
Source
杭州电子科技大学第三届程序设计大赛
题意:
给你0~n-1个点(围成一个环),从0开始每m个标记m+1这个点,如果所有的点都被标记就输出YES否则NO;
解:
设 xm>n时进入新的循环;
x*m%n得到就是每次新进入循环会位移的长度,为1时就会遍历整个环
x*m%n=x*m-(x*m/n)*n=x*m+y*n=gcd(n,m)

#include<iostream>
#include<cstdio>
using namespace std;
int x,y;
int gcd(int a,int b)
{
    return b ? gcd(b,a%b) :a;
}
int main()
{
    int a,b,t;
    while(cin>>t)
    {
        while(t--)
        {
            cin>>a>>b;
            if(gcd(a,b)==1)
            puts("NO");
            else
                puts("YES");
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值