HDU ACM 1222 Wolf and Rabbit

原题描述

Problem Description

There is a hill with n holes around. The holes are signed from 0 to n-1.

image

A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes.

Input

The input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648).

Output

For each input m n, if safe holes exist, you should output “YES”, else output “NO” in a single line.

Sample Input

2
1 2
2 2

Sample Output

NO
YES

解题思路

试验得出当m和n互质时,不存在安全的洞。所以本题可以转化为求最大公因数。
当最大公因数为1,则m和n互质,不存在安全洞;当最大公因数大于1,存在安全洞。

参考代码

/*
    HDU ACM 1222 Wolf and Rabbit
    Author: Scarb
    2016-3-15
*/
#include <iostream>
using namespace std;
__int64 gcd(__int64 a, __int64 b)   // a > b
{
    if (a < b)return gcd(b, a);
    if (!b)return a;
    return gcd(b, a%b);
}
int main()
{
    int p;
    __int64 m, n;
    cin >> p;
    while(p--)
    {
        cin >> m >> n;
        if (gcd(m, n) == 1)cout << "NO\n";
        else cout << "YES\n";
    }
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值