【HD 2141】Can you find it?

32 篇文章 0 订阅
3 篇文章 0 订阅

Can you find it?

Time Limit: 10000/3000 MS (Java/Others) Memory Limit: 32768/10000 K (Java/Others)
Total Submission(s): 23734 Accepted Submission(s): 6006

Problem Description
Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.

Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.

Output
For each case, firstly you have to print the case number as the form “Case d:”, then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print “YES”, otherwise print “NO”.

Sample Input
3 3 3
1 2 3
1 2 3
1 2 3
3
1
4
10

Sample Output
Case 1:
NO
YES
NO

Author
wangye

Source
HDU 2007-11 Programming Contest
————————————————————————————————————————————————————————————
输入一个值,判断是不是三个数组元素的组合,如果复杂度允许三个for最简单,然而显然不行。所以考虑到时搜索想到二分,由于二分的性质,又想到要合并数组,然后思路就出来了。
先把A.B数组合并成Sum,然后和减去c的输入值对比,二分。

——————————————————————————————————————————————

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream> 
#define N 515
using namespace std;

int a[N],b[N],c[N];
int sum[N*N];


int main()
{
    int al,bl,cl,i,sl,flag,cnt=1;
    while( ~scanf("%d%d%d",&al,&bl,&cl) )
    {
        for( i=0; i<al; i++ )
        {
            scanf("%d",&a[i]);
        }
        for( i=0; i<bl; i++ )
        {
            scanf("%d",&b[i]);
        }   
        for( i=0; i<cl; i++ )
        {
            scanf("%d",&c[i]);
        }
        int k=0,j;                         //输入 
        for( i=0; i<al; i++ )
        {
            for( j=0; j<bl; j++ )
            {
                sum[k++]=a[i]+b[j];      //数组合并 
            }
        }
        sort(sum,sum+k);     //排序 
        scanf("%d",&sl);
        printf("Case %d:\n", cnt++);
            while( sl-- )            //输入循环次数 (检测数据个数) 
            {
                flag=0;
                int s;
                scanf("%d",&s);
                for( i=0; i<cl; i++ )
                {
                    int l=0,r=k-1,mid;
                    int tt=s-c[i];
                    while( l <= r )
                    { //这个重组数组按照二分寻找和tt一样的值
                        mid = l+r>>1;
                        if( sum[mid] < tt )
                        {
                            l=mid+1;
                        }
                        else if( sum[mid] > tt)
                        {
                            r=mid-1;
                        }
                        else 
                        {
                            flag=1;
                            break;  
                        }
                    }
                    if( flag == 1 )
                    break;
                }
                if( flag )printf("YES\n");
                else printf("NO\n");
            }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值