hd2141 Can you find it?

Can you find it?

Time Limit: 10000/3000 MS (Java/Others)    Memory Limit: 32768/10000 K (Java/Others)
Total Submission(s): 16856    Accepted Submission(s): 4284

Problem Description
Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
 
Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
 
Output
For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".
 
Sample Input
  
  
3 3 3 1 2 3 1 2 3 1 2 3 3 1 4 10
 
Sample Output
  
  
Case 1: NO YES NO
 
嗯,题目大意就是说,给三个数组,然后再任给一个数,问这个数能否是三个数组里都拿出一个数的和。
嗯,我是用一个新的数组储存了后两个数组元素加和的所有情况,在sort 排序对于新数组和第一个数组,在二分查找。
嗯,注意一下,要用__int64//我错了,int型就足够了,请原谅
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
__int64 a[510],b[510],c[510],d[300010];
int flag;
int find(int k,__int64 t)
{
    int left,right,mid;
    left=0;
    right=k;
    while(right-left>=0)
    {
        mid=(right+left)/2;
        if(d[mid]==t)
            return 1;
        if(d[mid]<t)
            left=mid+1;
        else 
            right=mid-1;
    }
    return 0;
}
int main()
{
    int i,j,k,l,n,m,s,cnt=0;
    __int64 t;
    while(~scanf("%d %d %d",&l,&n,&m))
    {
        cnt++;
        printf("Case %d:\n",cnt);
        for(i=0;i<l;++i)
            scanf("%I64d",&a[i]);
        for(i=0;i<n;++i)
            scanf("%I64d",&b[i]);
        for(i=0;i<n;++i)
            scanf("%I64d",&c[i]);
        sort(a,a+l);//这个可以不要,刚试了一下,时间减少了100多ms
        memset(d,0,sizeof(d));
        for(i=0,k=0;i<n;++i)
        {
            for(j=0;j<m;++j)
            {
                d[k++]=b[i]+c[j];
            }
        }
        sort(d,d+k);
        scanf("%d",&s);
        while(s--)
        {
            flag=0;
            scanf("%I64d",&t);
            if(t<a[0]+d[0]||t>a[l-1]+d[k-1])
            {
                printf("NO\n");
                continue;
            }
            for(i=0;i<l;++i)
            {
                __int64 r=t-a[i];
                flag=find(k,r);//flag=binary_search(d,d+k,r);
                if(flag)
                    break;
            }
            if(flag)
                printf("YES\n");
            else 
                printf("NO\n");
        }
    }
    return 0;
}

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值