【Light OJ】1049 Farthest Nodes in a Tree(树的直径模板题)

Farthest Nodes in a Tree

Time Limit:2000MS Memory Limit:32768KB 64bit IO Format:%lld & %llu
Submit

Status
Description
Given a tree (a connected graph with no cycles), you have to find the farthest nodes in the tree. The edges of the tree are weighted and undirected. That means you have to find two nodes in the tree whose distance is maximum amongst all nodes.

Input
Input starts with an integer T (≤ 10), denoting the number of test cases.

Each case starts with an integer n (2 ≤ n ≤ 30000) denoting the total number of nodes in the tree. The nodes are numbered from 0 to n-1. Each of the next n-1 lines will contain three integers u v w (0 ≤ u, v < n, u ≠ v, 1 ≤ w ≤ 10000) denoting that node u and v are connected by an edge whose weight is w. You can assume that the input will form a valid tree.

Output
For each case, print the case number and the maximum distance.

Sample Input
2
4
0 1 20
1 2 30
2 3 50
5
0 2 20
2 1 10
0 3 29
0 4 50
Sample Output
Case 1: 100
Case 2: 80
FAQ | About Virtual Judge | Forum | Discuss | Open

————————————————————————————————————————————
今天做的特别晕,因为BFS学的不是特别好,在做题的时候除了套模板之外就只好干瞪眼,一天下来套了三四个模板,感觉不是太熟。题解也没时间写了,明天补上吧。

明天加油吧。
————————————————————————————————————————————

#include<cstdio> 
#include<cstring>
#include<iostream>
#include<queue>

using namespace std;

const int MAX_N = 30010;
int n;
struct EDGE{ 
    int from,to,val,next; //构造记录图的结构体,两个节点,一条边,一个连接
};
EDGE edge[MAX_N*2];
int head[MAX_N];
int edgenum;

void init()
{
    memset(head,-1,sizeof(head));
    edgenum = 0;    
}
void addEdge( int u,int v,int w )
{
    edge[edgenum].from = u; 
    edge[edgenum].to = v;
    edge[edgenum].val = w; // 边长(权值)
    edge[edgenum].next = head[u];
    head[u] = edgenum++;
}

bool vis[MAX_N];
int dis[MAX_N];
int ans;
int TODE;
void BFS( int s )
{
    memset(vis,false,sizeof(vis));
    memset(dis,0,sizeof(dis));
    queue<int>Q;    
    Q.push(s);  
    dis[s] = 0;
    ans = 0;
    vis[s] = true;
    while( Q.size() )
    {
        int u = Q.front();
        Q.pop();
        for( int i=head[u]; i!=-1; i = edge[i].next )
        {
            int v =edge[i].to;
            if( !vis[v])
            {
                if( dis[v] < dis[u] + edge[i].val )
                {
                    dis[v] = dis[u] + edge[i].val;

                }
                vis[v] = true;
                Q.push(v);
            }
        }
    }
    for( int i=0; i<n; i++ )
    {
        if( ans < dis[i] )      
        {
            ans = dis[i];
            TODE = i;
        }
    }   
}

int main()
{
    int m,a,b,l,t;
    char c;
    scanf("%d",&t);
    int haha = 0;
    while( t-- )
    {
        haha++;
        scanf("%d",&n);
        init();
        m=n-1;
        while( m-- )
        {
            scanf("%d %d %d",&a,&b,&l); 
            addEdge(a,b,l);
            addEdge(b,a,l);
        }
        BFS(0);
        BFS(TODE);
        printf("Case %d: %d\n",haha,ans);
    }
    return 0;
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值