A1050 String Subtraction

44 篇文章 0 订阅

在这里插入图片描述

Sample Input:

They are students.
aeiou

Sample Output:

Thy r stdnts.

solution

#include <stdio.h>
#include <string.h>
int main(){
	char s1[10005], s2[10005];
	int hash[130] = {0};
	gets(s1);
	gets(s2);
	for(int i = 0; i < strlen(s2); i++)
		hash[s2[i]]++;
	for(int j = 0; j < strlen(s1); j++){
		if(!hash[s1[j]]) printf("%c", s1[j]);
	}
	return 0;
} 
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值