Enchantment Mixtures(区间DP)

点击打开链接

题目描述
Harry Potter has n enchantment mixtures in front of him, arranged in a row. Each enchantment mixture has one of 100 different colors (colors have numbers from 0 to 99).

He wants to mix all these enchantment mixtures together. At each step, he is going to take two enchantment mixtures that stand next to each other and mix them together,

and put the resulting mixture in their place.

When mixing two enchantment mixtures of colors a and b, the resulting enchantment mixture will have the color (a+b) mod 100.

Also, there will be some smoke in the process. The amount of smoke generated when mixing two enchantment mixtures of colors a and b is a*b.

Find out what is the minimum amount of smoke that Harry can get when mixing all the enchantment mixtures together.

输入
Your program will be tested on one or more test cases. In each test cases, The first line of each test case will

contain n(1<=n<=100), the number of mixtures.
The second line will contain n integers between 0 and 99 - the initial colors of the mixtures.

输出


For each test case, print the following line:

answer

where answer is the minimum amount of smoke.



样例输入
2
18 19
3
40 60 20
样例输出
342
2400

题解:一道简单的区间DP题目,由于自己对于动态规划还是不怎么好,所以当时做的时候特困难,以后多加强学动态规划。
需要处理的就是,记录是对于大于100的要取余,这样sum[i][j]记录的则是取余之后的,操作后对于大于100的还要取余一次。

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<math.h>
#include<stdlib.h>
using namespace std;
#define INF 0x7ffffff
int main()
{
	int n,ss,min;
	int s[109],sum[109][109],dp[109][109];
	while(cin>>n)
	{
		for(int i=1;i<=n;i++)
			cin>>s[i];
		for(int i=1;i<=n;i++)
			for(int j=i;j<=n;j++){
				ss=0;
				for(int k=i;k<=j;k++)
					ss=(ss+s[k])%100;
				sum[i][j]=ss;
			}				
		memset(dp,0,sizeof(dp));
		for(int i=1;i<=n;i++)
			dp[i][i+1]=s[i]*s[i+1];
		for(int i=n-2;i>=1;i--){
			for(int j=i+2;j<=n;j++){
				dp[i][j]=INF;
				for(int k=i;k<j;k++){
					min=dp[i][k]+dp[k+1][j]+sum[i][k]*sum[k+1][j];
					if(min<dp[i][j]){
						dp[i][j]=min;
						sum[i][j]=(sum[i][k]+sum[k+1][j])%100;
					}
				}
			}
		}
		printf("%d\n",dp[1][n]);
	}
	return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值