127. ZigZagging on a Tree (30)

3 篇文章 0 订阅

127. ZigZagging on a Tree (30)

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in “zigzagging order” – that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<= 30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.
这里写图片描述
Output Specification:

For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1

Sample Output:

1 11 5 8 17 12 20 15

127. ZigZagging on a Tree (30)


/*************************************************************
Author : qmeng
MailTo : qmeng1128@163.com
QQ     : 1163306125
Blog   : http://blog.csdn.net/Mq_Go/
Create : 2018-03-03 16:02:07
Version: 1.0
**************************************************************/
#include <cstdio>
#include <iostream>
#include <queue>
#include <cstdlib>
#include <vector>
using namespace std;
const int MAX = 30;
struct Tree{
    Tree *le;
    Tree *ri;
    int data;
};
bool key = true;
Tree *Tr;
int in[MAX],pos[MAX];
int n;
queue<Tree *> que,queM;
vector<int> v1,v2;
Tree *buildTree(int il,int ir,int pl,int pr){
    if(pl>pr)return NULL;
    int p = il;
    while(in[p] != pos[pr])p++;

    Tree *root = (Tree *) malloc (sizeof(Tree));
    root->data = in[p];
    root->le = buildTree(il,p-1,pl,pr-ir+p-1);
    root->ri = buildTree(p+1,ir,pr-ir+p,pr-1);
    return root;

}
void printLevelTree1(Tree *root){    
    Tree *Tr = NULL;
    que.push(root);
    while(!que.empty()){
        Tree *Tr = que.front();
        que.pop();
        if(Tr==NULL)continue;
        v1.push_back(Tr->data);
        //printf("%d ",Tr->data);
        que.push(Tr->le);
        que.push(Tr->ri);
    }
}
void printLevelTree2(Tree *root){    
    Tree *Tr = NULL;
    que.push(root);
    while(!que.empty()){
        Tree *Tr = que.front();
        que.pop();
        if(Tr==NULL)continue;
        v2.push_back(Tr->data);
        //printf("%d ",Tr->data);
        que.push(Tr->ri);
        que.push(Tr->le);
    }
}
/*
1 11 5 12 17 8 20 15
1 5 11 8 17 12 15 20
*/
void print(int k){
    if(k>=n)return;
    int p = k;
    if(key == true){
        while(v1[p]!=v2[k]){
            printf(" %d",v1[p]);
            p++;
        }
        printf(" %d",v1[p]);
        key = false;
    }else{
        while(v2[p]!=v1[k]){
            printf(" %d",v2[p]);
            p++;
        }
        printf(" %d",v2[p]);
        key = true;
    }

    print(++p);
}
int main(){
    int i;
    scanf("%d",&n);
    for( i = 0 ; i < n ; i++)scanf("%d",&in[i]);
    for( i = 0 ; i < n ; i++)scanf("%d",&pos[i]);
    Tree *root =buildTree(0,n-1,0,n-1);
    printLevelTree1(root);
    printLevelTree2(root);
    printf("%d",v1[0]);
    print(1);

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值