PAT甲级 1015

Reversible Primes

A reversible prime in any number system is a prime whose “reverse” in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (< 105) and D (1 < D <= 10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line “Yes” if N is a reversible prime with radix D, or “No” if not.

Sample Input:
73 10
23 2
23 10
-2

Sample Output:
Yes
Yes
No


  1. 考点

    • 判断数是否为质数
  2. 题解

    • 先将十进制的n是否为质数
    • 将十进制的n化为D进制的数,然后反转,再转为十进制的数
    • 判断该数是否为质数
#include <stdio.h>
#include <vector>

using namespace std;
vector<bool> rst;
vector<int> r;

bool isPrime(int n){
  if(n==1)return false;
  int i;
  for(i=2;i*i<=n;i++){
    if(n%i==0)return false;
  }
  return true;
}

bool isReversible(int n,int d){
  if(!isPrime(n))return false;
  while(n>0){
    r.push_back(n%d);
    n/=d;
  }
  int i=0;
  for(auto it=r.begin();it!=r.end();it++){
    n=n*d+(*it);
  }
  r.clear();
  if(!isPrime(n))return false;
  return true;
}

int main(){
  //freopen("./in","r",stdin);
  int n,d;
  scanf("%d",&n);
  while(n>0){
    scanf("%d",&d);
    if(isReversible(n,d)){
      rst.push_back(true);
    }else{
      rst.push_back(false);
    }
    scanf("%d",&n);
  }

  for(auto it=rst.begin();it!=rst.end();it++){
    if(*it)printf("Yes\n");
    else printf("No\n");
  }

  return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值