PAT - 甲级 - 1015. Reversible Primes (20)(素数)

reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (< 105) and D (1 < D <= 10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line "Yes" if N is a reversible prime with radix D, or "No" if not.

Sample Input:
73 10
23 2
23 10
-2
Sample Output:
Yes
Yes
No

给定条件:
1.一个十进制数n
2.一个整数d ,1<d<=10

要求:
1.判断n是否为素数
2.判断n转换成d进制后,将数字变为“倒序”(如十进制1234倒过来为4321二进制1101倒过来为1011)然后再转换为10进制,是否为素数
3.如果两个都为素数,输出Yes否则输出No

求解:
1.按照题目要求进行编码即可


#include <cstdio>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;

int n, d, revNum;
vector<int> v;

bool isPrimeNum(int num) {
	if(num <= 1) return false;
	for(int i = 2; i <= sqrt(num); i++) {
		if(num % i == 0) {
			return false;
		}
	}
	return true;
}

int main() {
	while(scanf("%d", &n) != EOF) {
		if(n < 0) return 0;
		v.clear();
		scanf("%d", &d);

		if(isPrimeNum(n) == false) {
			printf("No\n");
			continue;
		}

		int temp = n;
		while(temp != 0) {
			v.push_back(temp%d);
			temp /= d;
		}
		
		revNum = 0;
		for(int i = 0; i < v.size(); i++) {
			revNum = revNum * d + v[i];
		}
		if(isPrimeNum(revNum)) {
			printf("Yes\n");
		} else {
			printf("No\n");
		}
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值