A reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.
Now given any two positive integers N (< 105) and D (1 < D <= 10), you are supposed to tell if N is a reversible prime with radix D.
Input Specification:
The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.
Output Specification:
For each test case, print in one line "Yes" if N is a reversible prime with radix D, or "No" if not.
Sample Input:73 10 23 2 23 10 -2Sample Output:
Yes Yes No
给定条件:
1.一个十进制数n
2.一个整数d ,1<d<=10
要求:
1.判断n是否为素数
2.判断n转换成d进制后,将数字变为“倒序”(如十进制1234倒过来为4321二进制1101倒过来为1011)然后再转换为10进制,是否为素数
3.如果两个都为素数,输出Yes否则输出No
求解:
1.按照题目要求进行编码即可
#include <cstdio>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;
int n, d, revNum;
vector<int> v;
bool isPrimeNum(int num) {
if(num <= 1) return false;
for(int i = 2; i <= sqrt(num); i++) {
if(num % i == 0) {
return false;
}
}
return true;
}
int main() {
while(scanf("%d", &n) != EOF) {
if(n < 0) return 0;
v.clear();
scanf("%d", &d);
if(isPrimeNum(n) == false) {
printf("No\n");
continue;
}
int temp = n;
while(temp != 0) {
v.push_back(temp%d);
temp /= d;
}
revNum = 0;
for(int i = 0; i < v.size(); i++) {
revNum = revNum * d + v[i];
}
if(isPrimeNum(revNum)) {
printf("Yes\n");
} else {
printf("No\n");
}
}
return 0;
}