HDU 5813 Elegant Construction (贪心)

32 篇文章 0 订阅


Elegant Construction

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1034    Accepted Submission(s): 543
Special Judge


Problem Description
Being an ACMer requires knowledge in many fields, because problems in this contest may use physics, biology, and even musicology as background. And now in this problem, you are being a city architect!
A city with N towns (numbered 1 through N) is under construction. You, the architect, are being responsible for designing how these towns are connected by one-way roads. Each road connects two towns, and passengers can travel through in one direction.

For business purpose, the connectivity between towns has some requirements. You are given N non-negative integers a1 .. aN. For 1 <= i <= N, passenger start from town i, should be able to reach exactly ai towns (directly or indirectly, not include i itself). To prevent confusion on the trip, every road should be different, and cycles (one can travel through several roads and back to the starting point) should not exist.

Your task is constructing such a city. Now it's your showtime!
 

Input
The first line is an integer T (T <= 10), indicating the number of test case. Each test case begins with an integer N (1 <= N <= 1000), indicating the number of towns. Then N numbers in a line, the ith number ai (0 <= ai < N) has been described above.
 

Output
For each test case, output "Case #X: Y" in a line (without quotes), where X is the case number starting from 1, and Y is "Yes" if you can construct successfully or "No" if it's impossible to reach the requirements.

If Y is "Yes", output an integer M in a line, indicating the number of roads. Then M lines follow, each line contains two integers u and v (1 <= u, v <= N), separated with one single space, indicating a road direct from town u to town v. If there are multiple possible solutions, print any of them.
 

Sample Input
  
  
3 3 2 1 0 2 1 1 4 3 1 1 0
 

Sample Output
  
  
Case #1: Yes 2 1 2 2 3 Case #2: No Case #3: Yes 4 1 2 1 3 2 4 3 4
 

Author
SYSU
 

Source
 

题意:有向图,给你n个顶点,设置每个顶点应该连接几个,求出接连的方案,边数没有要求。

POINT:

既然边数没有要求,就从要求少的排序,每次都往最前面开始连,虽然这样边是最多的。但也是最简单的。

当时没有过也是题意看不完全的原因。

#include <iostream>
#include <string.h>
#include <stdio.h>
#include <queue>
#include <algorithm>
#include <math.h>
using namespace std;
struct node
{
    int num;
    int i;
}a[1010];
bool cmd(node a,node b)
{
    return a.num<b.num;
}
int mp[1010][1010];
int main()
{
    int T;
    scanf("%d",&T);
    int p=0;
    while(T--)
    {
        int n;
        scanf("%d",&n);
        memset(mp,0,sizeof mp);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i].num);
            a[i].i=i;
        }
        sort(a+1,a+1+n,cmd);
        int flag=1;
        int ans=0;
        for(int i=1;i<=n;i++)
        {
            if(a[i].num>=i)
            {
                flag=0;
                break;
            }
            else
            {
                for(int j=1;j<=a[i].num;j++)
                {
                    mp[a[i].i][a[j].i]=1;
                }
                ans+=a[i].num;
            }
        }
        if(flag)
        {
            printf("Case #%d: Yes\n%d\n",++p,ans);
            for(int i=1;i<=n;i++)
            {
                for(int j=1;j<=n;j++)
                {
                    if(mp[i][j]) printf("%d %d\n",i,j);
                }
            }
            
        }
        else
            printf("Case #%d: No\n",++p);
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值