HDU 5821 Ball(贪心)

32 篇文章 0 订阅

Ball

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1074    Accepted Submission(s): 645


Problem Description
ZZX has a sequence of boxes numbered  1,2,...,n . Each box can contain at most one ball.

You are given the initial configuration of the balls. For  1in , if the  i -th box is empty then  a[i]=0 , otherwise the i-th box contains exactly one ball, the color of which is a[i], a positive integer. Balls with the same color cannot be distinguished.

He will perform m operations in order. At the i-th operation, he collects all the balls from boxes l[i],l[i]+1,...,r[i]-1,r[i], and then arbitrarily put them back to these boxes. (Note that each box should always contain at most one ball)

He wants to change the configuration of the balls from a[1..n] to b[1..n] (given in the same format as a[1..n]), using these operations. Please tell him whether it is possible to achieve his goal.
 

Input
First line contains an integer t. Then t testcases follow. 
In each testcase: First line contains two integers n and m. Second line contains a[1],a[2],...,a[n]. Third line contains b[1],b[2],...,b[n]. Each of the next m lines contains two integers l[i],r[i].

1<=n<=1000,0<=m<=1000, sum of n over all testcases <=2000, sum of m over all testcases <=2000.

0<=a[i],b[i]<=n.

1<=l[i]<=r[i]<=n.
 

Output
For each testcase, print "Yes" or "No" in a line.
 

Sample Input
  
  
5 4 1 0 0 1 1 0 1 1 1 1 4 4 1 0 0 1 1 0 0 2 2 1 4 4 2 1 0 0 0 0 0 0 1 1 3 3 4 4 2 1 0 0 0 0 0 0 1 3 4 1 3 5 2 1 1 2 2 0 2 2 1 1 0 1 3 2 4
 

Sample Output
  
  
No No Yes No Yes
 

Author
学军中学
 

Source
 



题意:

经过给出的m次操作,判断能否从序列1变为序列2。一次操作:从把a到b的球全部拿出来,重新放入a到b个箱子。每个箱子最多只能放一个球。

POINT:

两个for循环来寻找序列1中的每个元素应该放置到序列2的哪个位置,记录cnt[]数组,cnt[i]代表序列1中的第i个箱子应该和序列2中的cnt[i]箱子匹配。每次操作给cnt数组排序。

这样就只要看cnt[i]=i,就是匹配成功,要匹配成功就是每个cnt都相等。

#include <iostream>
#include <string.h>
#include <stdio.h>
#include <stack>
#include <algorithm>
#include <math.h>
using namespace std;
#define ll long long
const int N = 1010;
int cnt[N];
int a[N],b[N];
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n,m;
        scanf("%d %d",&n,&m);
        for(int i=1;i<=n;i++) scanf("%d",&a[i]);
        for(int i=1;i<=n;i++) scanf("%d",&b[i]);
        int vis[N];
        memset(vis,0,sizeof vis);
        int ans=1;
        for(int i=1;i<=n;i++)
        {
            int j;
            for(j=1;j<=n;j++)
            {
                if(a[i]==b[j])
                {
                    if(!vis[j])
                    {
                        vis[j]=1;
                        cnt[i]=j;
                        break;
                    }
                }
            }
            if(j==n+1)
            {
                ans=0;
                break;
            }
        }
        while(m--)
        {
            int a,b;
            scanf("%d %d",&a,&b);
            sort(cnt+a,cnt+b+1);
        }
        for(int i=1;i<=n;i++)
        {
            if(i!=cnt[i])
            {
                ans=0;
                break;
            }
        }
        if(!ans)
        {
            printf("No\n");
        }
        else printf("Yes\n");

    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值