HDU 4027 Can you answer these queries? (线段树 区间开方)

29 篇文章 0 订阅

Can you answer these queries?

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 17354    Accepted Submission(s): 4066


Problem Description
A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of the weapon, so he asks you for help.
You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line.

Notice that the square root operation should be rounded down to integer.
 

Input
The input contains several test cases, terminated by EOF.
  For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000)
  The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 2 63.
  The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000)
  For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive.
 

Output
For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.
 

Sample Input
  
  
10 1 2 3 4 5 6 7 8 9 10 5 0 1 10 1 1 10 1 1 5 0 5 8 1 4 8
 

Sample Output
  
  
Case #1: 19 7 6
 

Source
 
题意:
两个操作,一个区间每个数开方和输出区间和。

POINT:
因为开方很快就会变成1,变成1就不用开方了,所以如果区间内全是1,就剪掉这种情况。
注意这题有l>r的情况,一直被WA,也不知道作者怎么想的,也没特殊说明。怪我太不仔细??

#include <iostream>
#include <stdio.h>
#include <math.h>
#include <string.h>
using namespace std;
const int N = 100060*4;
#define lt 2*x
#define rt 2*x+1
#define LL long long
LL a[N];
LL sum[N];
void build(int x,int l,int r)
{
    if(l==r) sum[x]=a[l];
    else
    {
        int mid=(l+r)>>1;
        build(lt,l,mid);
        build(rt,mid+1,r);
        sum[x]=sum[lt]+sum[rt];
    }
}
LL output(int x,int l,int r,int ll,int rr)
{
    LL ans=0;
    if(ll<=l&&rr>=r) ans+=sum[x];
    else
    {
        int mid=(l+r)>>1;
        if(ll<=mid) ans+=output(lt,l,mid,ll,rr);
        if(mid<rr) ans+=output(rt,mid+1,r,ll,rr);
    }
    return ans;
}
void srt(int x,int l,int r,int ll,int rr)
{
    if(sum[x]==r-l+1) return;
    if(l==r) sum[x]=(LL)sqrt(sum[x]);
    else
    {
        int mid=(l+r)>>1;
        if(ll<=mid) srt(lt,l,mid,ll,rr);
        if(mid<rr) srt(rt,mid+1,r,ll,rr);
        sum[x]=sum[lt]+sum[rt];
    }
}
int main()
{
    int n;
    int p=0;
    while(~scanf("%d",&n))
    {
        for(int i=1;i<=n;i++)
        {
            scanf("%lld",&a[i]);
        }
        build(1,1,n);
        int q;
        scanf("%d",&q);
        printf("Case #%d:\n",++p);
        while(q--)
        {
            int k,l,r;
            scanf("%d %d %d",&k,&l,&r);
            if(l>r) swap(l,r);//这题有l比r大的情况,真是要死了。
            if(k)
            {
                LL ans=output(1,1,n,l,r);
                printf("%lld\n",ans);
            }
            else
            {
                srt(1,1,n,l,r);
            }
        }
        printf("\n");//每个样例后有空行。
        
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值