HDU 1198 Farm Irrigation (BFS)

7 篇文章 0 订阅

Farm Irrigation

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10465    Accepted Submission(s): 4601


Problem Description
Benny has a spacious farm land to irrigate. The farm land is a rectangle, and is divided into a lot of samll squares. Water pipes are placed in these squares. Different square has a different type of pipe. There are 11 types of pipes, which is marked from A to K, as Figure 1 shows.


Figure 1


Benny has a map of his farm, which is an array of marks denoting the distribution of water pipes over the whole farm. For example, if he has a map 

ADC
FJK
IHE

then the water pipes are distributed like 


Figure 2


Several wellsprings are found in the center of some squares, so water can flow along the pipes from one square to another. If water flow crosses one square, the whole farm land in this square is irrigated and will have a good harvest in autumn. 

Now Benny wants to know at least how many wellsprings should be found to have the whole farm land irrigated. Can you help him? 

Note: In the above example, at least 3 wellsprings are needed, as those red points in Figure 2 show.
 

Input
There are several test cases! In each test case, the first line contains 2 integers M and N, then M lines follow. In each of these lines, there are N characters, in the range of 'A' to 'K', denoting the type of water pipe over the corresponding square. A negative M or N denotes the end of input, else you can assume 1 <= M, N <= 50.
 

Output
For each test case, output in one line the least number of wellsprings needed.
 

Sample Input
  
  
2 2 DK HF 3 3 ADC FJK IHE -1 -1
 

Sample Output
  
  
2 3
 

Author
ZHENG, Lu
 

Source
 

题意:
给你水管图,让你求出联通水管的根数。

POINT:
另类的简单BFS,关键是如何把代码写的简单。

#include<iostream>
#include<stdio.h>
#include<string.h>
#include <algorithm>
#define LL long long
using namespace std;
const int maxn = 55;
char mp[maxn][maxn];
int vis[maxn][maxn];
#define ss if(shang(x-1,y)) dfs(x-1,y);
#define zz if(zuo(x,y-1)) dfs(x,y-1);
#define yy if(you(x,y+1)) dfs(x,y+1);
#define xx if(xia(x+1,y)) dfs(x+1,y);
int ans,n,m;
void init()
{
    memset(mp,0,sizeof mp);
    memset(vis,0,sizeof vis);
    ans=0;
}
bool zuo(int x,int y)
{
    if(x<1||x>n||y<1||y>m) return 0;
    if(mp[x][y]=='B'||mp[x][y]=='D'||mp[x][y]=='F'||mp[x][y]=='G'||mp[x][y]=='I'||mp[x][y]=='J'||mp[x][y]=='K')
        return 1;
    return 0;
}
bool you(int x,int y)
{
    if(x<1||x>n||y<1||y>m) return 0;
    if(mp[x][y]=='A'||mp[x][y]=='C'||mp[x][y]=='F'||mp[x][y]=='G'||mp[x][y]=='H'||mp[x][y]=='I'||mp[x][y]=='K')
        return 1;
    return 0;
}
bool xia(int x,int y)
{
    if(x<1||x>n||y<1||y>m) return 0;
    if(mp[x][y]=='A'||mp[x][y]=='B'||mp[x][y]=='E'||mp[x][y]=='G'||mp[x][y]=='H'||mp[x][y]=='J'||mp[x][y]=='K')
        return 1;
    return 0;
}
bool shang(int x,int y)
{
    if(vis[x][y]==1) return 0;
    if(x<1||x>n||y<1||y>m) return 0;
    if(mp[x][y]=='C'||mp[x][y]=='D'||mp[x][y]=='E'||mp[x][y]=='H'||mp[x][y]=='I'||mp[x][y]=='J'||mp[x][y]=='K')
        return 1;
    return 0;
}
void dfs(int x,int y)
{
    if(vis[x][y]==1) return;
    vis[x][y]=1;
    switch(mp[x][y])
    {
        case 'A':{
            ss
            zz
            break;
        }
        case 'B':{
            ss
            yy
            break;
        }
        case 'C':{
            zz
            xx
            break;
        }
        case 'D':{
            xx
            yy
            break;
        }
        case 'E':{
            ss
            xx
            break;
        }
        case 'F':{
            yy
            zz
            break;
        }
        case 'G':{
            ss
            zz
            yy
            break;
        }
        case 'H':{
            zz
            ss
            xx
            break;
        }
        case 'I':{
            zz
            yy
            xx
            break;
        }
        case 'J':{
            ss
            xx
            yy
            break;
        }
        case 'K':{
            ss
            xx
            zz
            yy
            break;
        }
            
            
            
        
    }
}
int main()
{
    while(~scanf("%d %d",&n,&m))
    {
        if(n==-1) break;
        init();
        for(int i=1;i<=n;i++) scanf("%s",mp[i]+1);
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=m;j++)
            {
                if(!vis[i][j])
                {
                    ans++;
                    dfs(i,j);
                }
            }
        }
        printf("%d\n",ans);
        
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
本系统的研发具有重大的意义,在安全性方面,用户使用浏览器访问网站时,采用注册和密码等相关的保护措施,提高系统的可靠性,维护用户的个人信息和财产的安全。在方便性方面,促进了校园失物招领网站的信息化建设,极大的方便了相关的工作人员对校园失物招领网站信息进行管理。 本系统主要通过使用Java语言编码设计系统功能,MySQL数据库管理数据,AJAX技术设计简洁的、友好的网址页面,然后在IDEA开发平台中,编写相关的Java代码文件,接着通过连接语言完成与数据库的搭建工作,再通过平台提供的Tomcat插件完成信息的交互,最后在浏览器中打开系统网址便可使用本系统。本系统的使用角色可以被分为用户和管理员,用户具有注册、查看信息、留言信息等功能,管理员具有修改用户信息,发布寻物启事等功能。 管理员可以选择任一浏览器打开网址,输入信息无误后,以管理员的身份行使相关的管理权限。管理员可以通过选择失物招领管理,管理相关的失物招领信息记录,比如进行查看失物招领信息标题,修改失物招领信息来源等操作。管理员可以通过选择公告管理,管理相关的公告信息记录,比如进行查看公告详情,删除错误的公告信息,发布公告等操作。管理员可以通过选择公告类型管理,管理相关的公告类型信息,比如查看所有公告类型,删除无用公告类型,修改公告类型,添加公告类型等操作。寻物启事管理页面,此页面提供给管理员的功能有:新增寻物启事,修改寻物启事,删除寻物启事。物品类型管理页面,此页面提供给管理员的功能有:新增物品类型,修改物品类型,删除物品类型。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值