HDU 1198 - Farm Irrigation(搜索)

Farm Irrigation

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8990 Accepted Submission(s): 3884

Problem Description
Benny has a spacious farm land to irrigate. The farm land is a rectangle, and is divided into a lot of samll squares. Water pipes are placed in these squares. Different square has a different type of pipe. There are 11 types of pipes, which is marked from A to K, as Figure 1 shows.

Figure 1

Benny has a map of his farm, which is an array of marks denoting the distribution of water pipes over the whole farm. For example, if he has a map
1
ADC
FJK
IHE

then the water pipes are distributed like

2

Figure 2

Several wellsprings are found in the center of some squares, so water can flow along the pipes from one square to another. If water flow crosses one square, the whole farm land in this square is irrigated and will have a good harvest in autumn.

Now Benny wants to know at least how many wellsprings should be found to have the whole farm land irrigated. Can you help him?

Note: In the above example, at least 3 wellsprings are needed, as those red points in Figure 2 show.

Input
There are several test cases! In each test case, the first line contains 2 integers M and N, then M lines follow. In each of these lines, there are N characters, in the range of ‘A’ to ‘K’, denoting the type of water pipe over the corresponding square. A negative M or N denotes the end of input, else you can assume 1 <= M, N <= 50.

Output
For each test case, output in one line the least number of wellsprings needed.

Sample Input
2 2
DK
HF

3 3
ADC
FJK
IHE

-1 -1

Sample Output
2
3

搜索思路:
对每种地图打表,1,0标志连通度,然后DFS.

AC代码

#include<stdio.h>
//above,right,under,left
//   0    1     2     3
int qdu[11][4] = {
{1,0,0,1},
{1,1,0,0},
{0,0,1,1},
{0,1,1,0},
{1,0,1,0},
{0,1,0,1},
{1,1,0,1},
{1,0,1,1},
{0,1,1,1},
{1,1,1,0},
{1,1,1,1}
};
char farm[50][50];
int m;
int n;
int dfs(int x,int y)
{
    int tx;
    int ty;
    //above
    int flag_a = 0;
    tx = x - 1;
    ty = y;
    if(tx >= 0)
    {
        if(qdu[farm[x][y]-'A'][0] && qdu[farm[tx][ty]-'A'][2])
        {
            flag_a = 1;
        }
    }
    //right
    int flag_r = 0;
    tx = x;
    ty = y + 1;
    if(ty < n)
    {
        if(qdu[farm[x][y]-'A'][1] && qdu[farm[tx][ty]-'A'][3])
        {
            flag_r = 1;
        }
    }
    //under
    int flag_u = 0;
    tx = x + 1;
    ty = y;
    if(tx < m)
    {
        if(qdu[farm[x][y]-'A'][2] && qdu[farm[tx][ty]-'A'][0])
        {
            flag_u = 1;
        }
    }
    //left
    int flag_l = 0;
    tx = x;
    ty = y - 1;
    if(ty >= 0)
    {
        if(qdu[farm[x][y]-'A'][3] && qdu[farm[tx][ty]-'A'][1])
        {
            flag_l = 1;
        }
    }
    farm[x][y] = 'A'-1;//这里注意要先标志四个方向的连通情况,再标志,再DFS
    if(flag_a)
        dfs(x-1,y);
    if(flag_r)
        dfs(x,y+1);
    if(flag_u)
        dfs(x+1,y);
    if(flag_l)
        dfs(x,y-1);
    return 0;
}
int main()
{
    while(~scanf("%d%d",&m,&n))
    {
        getchar();
        int cnt = 0;
        if(m <= 0 || n <= 0) break;
        for(int i = 0;i < m;i++) gets(farm[i]);
        for(int i = 0;i < m;i++)
        {
            for(int j = 0;j < n;j++)
            {
                if(farm[i][j]-'A' != -1)
                {
                    cnt++;
                    dfs(i,j);
                }
            }
        }
        printf("%d\n",cnt);

    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值