FZU 2111 - Min Number (贪心)

17 篇文章 0 订阅
 Problem 2111 Min Number

Accept: 983    Submit: 1927
Time Limit: 1000 mSec    Memory Limit : 32768 KB

 Problem Description

Now you are given one non-negative integer n in 10-base notation, it will only contain digits ('0'-'9'). You are allowed to choose 2 integers i and j, such that: i!=j, 1≤i<j≤|n|, here |n| means the length of n’s 10-base notation. Then we can swap n[i] and n[j]. 

For example, n=9012, we choose i=1, j=3, then we swap n[1] and n[3], then we get 1092, which is smaller than the original n.

Now you are allowed to operate at most M times, so what is the smallest number you can get after the operation(s)?

Please note that in this problem, leading zero is not allowed!

 Input

The first line of the input contains an integer T (T≤100), indicating the number of test cases.

Then T cases, for any case, only 2 integers n and M (0≤n<10^1000, 0≤M≤100) in a single line.

 Output

For each test case, output the minimum number we can get after no more than M operations.

 Sample Input

3
 9012 0
 9012 1
 9012 2

 Sample Output

9012
 1092
 1029

 Source

“高教社杯”第三届福建省大学生程序设计竞赛


题意:
给你一个数,一个n,你可以交换n次数的位置,不能有前置0,输出最小的答案。

POINT:
贪心,每次找最前面的和最小的且最后面的换。

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
const int maxn  = 1111;
int a[maxn];
char s[maxn];
int main()
{
    int m,T;
    for(scanf("%d",&T);T;T--){
        scanf("%s%d",s,&m);
        int flag=1;
        int len=strlen(s);
        for(int i=0;i<len;i++) a[i+1]=s[i]-'0';
        int now=1;
        while(m&&now<=len){
            if(now==1){
                int aim=a[now];
                int Min=aim-1;
                int k=0;
                for(int i=now+1;i<=len;i++){
                    if(a[i]!=0&&Min>=a[i]){
                        k=i;
                        Min=a[i];
                    }
                }
                if(k==0||a[k]==a[now]){
                    now++;
                    continue;
                }
                swap(a[k], a[now]);
                m--;

            }else{
                int aim=a[now];
                int Min=aim-1;
                int k=0;
                for(int i=now+1;i<=len;i++){
                    if(Min>=a[i]){
                        k=i;
                        Min=a[i];
                    }
                }
                if(k==0||a[k]==a[now]){
                    now++;
                    continue;
                }
                swap(a[k], a[now]);
                m--;
            }
        }
        for(int i=1;i<=len;i++){
            printf("%d",a[i]);
        }
        printf("\n");
    }

    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值