How Many Equations Can You Find

How Many Equations Can You Find

Now give you an string which only contains 0, 1 ,2 ,3 ,4 ,5 ,6 ,7 ,8 ,9.You are asked to add the sign ‘+’ or ’-’ between the characters. Just like give you a string “12345”, you can work out a string “123+4-5”. Now give you an integer N, please tell me how many ways can you find to make the result of the string equal to N .You can only choose at most one sign between two adjacent characters.
Input
Each case contains a string s and a number N . You may be sure the length of the string will not exceed 12 and the absolute value of N will not exceed 999999999999.
Output
The output contains one line for each data set : the number of ways you can find to make the equation.
Sample Input
123456789 3
21 1
Sample Output
18
1

#include <cstdio>
#include <cstring>
const int MAX=1e7;
char str[MAX];
int n,len,cut;
void dfs(int l,__int64 sum)
{
	 if(l == len&& sum == n)
	    {
	    	cut++;
	    	return ;
		}
	  __int64 ans=0;
	  for(int i= l;i < len ;i++)
	     {
	     	     ans=ans*10+(str[i]-'0');
	     	     dfs(i+1,sum+ans);
				  if(l)
	     	     dfs(i+1,sum-ans);
		 }
}
int main()
{ 
    while(~scanf("%s %d",str,&n))
    {
        	  cut=0;
			 len=strlen(str);
             dfs(0,0);
             printf("%d\n",cut);
	}
	return 0;
}


  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值