Count the string

5 篇文章 0 订阅

It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example: 
s: "abab" 
The prefixes are: "a", "ab", "aba", "abab" 
For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab", it is 2 + 2 + 1 + 1 = 6. 
The answer may be very large, so output the answer mod 10007. 
Input
The first line is a single integer T, indicating the number of test cases. 
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters. 
Output
For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.
Sample Input
1
4
abab
Sample Output
6


题意:一个字符串的子串在该字符串出现的次数之和

       例如:

              字符串abab

            子串: a , ab , aba , abab

  出现的次数:2 + 2  +  1   +  1    =  6

如果用循环来做的话,N比较大,所以会超时,那应该怎么做呢 ?

这里就用到了next[ ]的特点了,利用DP , 看来DP学不好也不行啊。。。。

 next[ ]表示的是最大前缀和 和 后缀和的字符串长度

         dp[ i ] = dp[ next[i] ] + 1;

 也就是说next[ i ] 不等于0的话

         那么子串出现的次数至少有2次

#include <iostream>
#include <cstdio>
#include <cstring>
#define Mod 10007
const int MAX=2e5+10;
char str[MAX] ;
int next[MAX] , dp[MAX];
void getnext(int n)
{
	  int j = -1 , i =0;
	  next[0] = -1;
	   while(i < n)
	   {
	   	    if( j == -1 || str[i] == str[j])
	   	      {
	   	      	        i++;
						j++;
						next[i] = j;	   
				}
				else
				{
					 j = next[j];
				}
	   }
}
int main()
{   
    int t;
       scanf("%d",&t);
    while(t--)
   {
   	     int n;
   	     scanf("%d",&n);
   	       scanf("%s",str);
   	          getnext(n);
   	          memset(dp , 0 , sizeof(dp));
   	          int sum = 0;
   	          for(int i = 1; i <= n; i++)
   	            {
   	            	   dp[i] = dp[next[i]] + 1;
   	            	   sum += dp[i]%Mod;
				   }
				   printf("%d\n",sum%Mod);
   }    
	return 0;
}








  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值